Bad File Imports/Opening

Here is a step file that gets jacked up in 6, displays correctly in 5. thank you (1.3 MB)

It seems that some old native files are opening up jacked as well. Seeing this so far in 5 files and counting. thank you.

I now tried importing that file into Rhino 6 WIP and it looks fine here (and the same as it looks in Rhino on Windows). Could you make sure that that file is the one that is misbehaving on your system?

Yeah, i just downloaded it and opened. this is what i get.

Did you Open the STP file or Import it?
Please be very specific with the details of exactly how you opened/imported the file.

FWIW, I tried both opening and importing - both with the same and good results…

same here.
I can’t get it to screw (2.0 MB)

Can you open the resulting 3dm file?

here’s another file

Pro (3.2 MB)

edit: it’s a visual thing, the model isn’t bad

It look like the same display problem as this : Phantom lines in shaded display mode

“It should be fixed next tuesday”

If you are using clipping planes AND have an AMD GPU then the display goes nuts. Turn the clipping planes off for now to get around the issue. This will be fixed in the next WIP.

Boy - glad it’s the display going nuts and not me - that was the first file that I downloaded and opened on a Mac - ever…

this is what i get when i open that file

i’m not using clipping planes though.

Please run the Rhino SystemInfo command and return the results in a reply.

@wim are you testing with the latest dujour build for Mac?

here’s the result.

Untitled.txt (9.3 KB)

I’m on 6.10.18241.11346
I haven’t connected the Mac to anything McNeel and downloaded that from the link posted on Discourse.

If you’re willing to try, here is a brand new build that has my fix in it from last night.

I suspect that you are seeing a different manifestation of the bug that I fixed, but I can’t be sure. If you do try this build, please let me know if things look better. Thanks.

Winner, Winner!

This build fixes it.

Whew! Thanks for being the guinea pig and letting me know.

no problem. thanks for the fix.