Importing a STP (ASM file) creates strange curves and objects


#1

Hello there,

I am a new guy here. Nice to meet you all.

I am experiencing an issue when I am importing a complex assembly file (exported from Pro-E or Solidworks)
It comes with a lot of strange curves (lines) and some surfaces that do not belong to the original 3D model.
I have to explode a lot of blocks and objects in order to delete the unwanted curves. But I am not able to get rid of the strange surfaces that are somehow connected to an original surface.
Any idea how I should deal with this in a more simple way?

Thanks in advance,

Waikit


(Willem Derks) #2

Hi Waikit,

Without seeing the actual geometry it is difficult to say what might be wrong.
Maybe someone else will chime in with experience importing STP’s with these symptoms and a possible solution.
I strongly advice you to either post the STP file and resulting import here, or you can also Upload these files
to McNeel: http://www.rhino3d.com/upload

Note that these file will be treated with integrity. However uploading here or to McNeel offers 2 advantages:
1: You might get a fast and to the point solution
2: It allows McNeel to improve their importer and or fix bugs; in turn improving Rhino itself.

You might want to isolate the problematic surfaces and save only those in a file, to reduce the filesizes.

HTH
-Willem


#3

EDIT:

Edit: You can also try and open the Solid Works file directly in Rhino (end of edit)

Hi, this can happen with both STEP and IGES files.

What happens (and I don’t know why) is that these errors are due to trimmed surfaces where the trimming has gone bad, so either the wrong part has been removed, or they have not been trimmed at all.

First thing you can do is to try and open it in Rhino 4. It might help.
Or try and export with a slightly different setting if possible.

Regarding STEP and naked edges I have addressed the following on a few occasions: There is no tolerance overriding option in Rhino, and Solid Works tend to export the STEP at a higher tolerance than the original SW file, and Rhino 5 was altered so it is nit-picking at these numbers, resulting in errors that Rhino 4 would ignore. So these are actual SW errors that Rhino used to “accept”, but don’t any more. Rhino is “right”, but it is a problem for the user.

Hopefully we will get a tolerance overriding option for V6.


(Pascal Golay) #4

Hi Wikit- please send us one of these files if you can- tech@mcneel.com, Att’n Pascal, The smallest/simplest file that shows the problem would be the most useful. As for the extra curves, my guess is this is controlled at the export end of things, i.e. in ProE or SW - from Rhino’s perspective, if the data are in the file, we’ll try to read them in. But, send a file, if you can, and we’ll take a look.

-Pascal


#5

Hi all,

Thank you all for your advise.
Unfortuntately I am not able to share the confidential file or image.
I will meet the engineer soon who sent me the file, and will ask how he export the things from his end.
Perhaps those are curves that he used to to make the 3D model…
The way I solved this now, is to explode the blocks into objects until I can select the unwanted curves separately and delete them.

Regards,

Waikit


#6

+1
Same experience here - wrong trimmed surfaces and a much to tight tolerance.


#7

Explodeblock is a command to explode the block and all nested blocks, with out exploding the parts.

You can also double click a block to open it, and then go through every nested block to delete the curves, if you need to keep the block structure.

edit: Or if sufficient: just make a display mode that does not show curves.


#8

Hello all,

I think I figured out the issue.

  1. Strange curves appear, because the model was exported together with the construction lines that were used in pro-e
  2. Strange surfaces appear, because the model was exported with other ‘surface’ options selected. The only option that should be selected is ‘solid’ when exporting
  3. For the blocks, i have to explode them until objects are created in Rhino

Thanks for all the comments though


#9

Just so you know:
When exploding blocks you can use the ExplodeBlock command to explode all levels of linked blocks.