HELP! Cannot open a 3dm file

When I try to open my file, the error window come up and says my file is not a Rhino m_archive and failed to open. Can someone please help me to get my file back please? Thanks!

Can you upload the file for other people to try to open on their machine?

I can but I don’t think it is gona work because I tried to open on my another computer. :frowning:
Thanks for the comment.

Parts of a 3dm file can be read in notepad and that might help with finding the issue in where the corruption is.

I tried it on mine, still doesn’t work

Please upload your file, either onto this forum or confidentially through McNeel’s upload page, otherwise people cannot help you.

I did upload the file to the McNeel’s upload page but I haven’t got a respond from the technician. I will upload the file to the forum later. Thanks!

Here is a link to my file. Thank you guys if someone could help me fix the issue.

It seems your file is damaged to a great extent and beyond repair.

That’s sad to hear but thanks for the help tho.

Hi - if you are using the macOS Time Machine, you might have an older version of that file somewhere.
Was this file saved on the local disk or on a network of some kind?

Hi, I didn’t have a backup on time machine. And the file was just save on desktop.

Have you tried to insert or import it in a new file? It worked for me once. I hope that helps.

I tried that, and it didn’t work. :frowning:

I am sorry to hear that. I’ve tried changing the extension of your uploaded file to .3ds and it opens in Rhino, but seems to be empty, it appears only one layer named Fbx_Root. Maybe you lost your link to the data, if it is linked.

I recommend though, you don’t keep the files on your desktop, computer will be slower and the files can be easily damaged.

I hope someone can help you.

Thank you for your help and your advice.