STEP file import


#1

Hi
I’m having trouble importing a STEP file produced by Pro Engineer into Rhino. I have the latest SR6 of Rhino 64 bit for Windows. It seems to be an incorrect trimming problem, as parts of surfaces which should be trimmed away are still there. The same STEP file does displays correctly trimmed as expected in STPViewer so think the STEP file is probably OK. I can send the STEP file which is causing trouble if it helps.
Does anyone have any ideas how to fix this? Thanks.

Files now attached with STEP file and screenshots showing what it should look like (STP Viewer) and how Rhino imports it

Matthew Cox

1087758_asm_solids_shells.stp (248.0 KB)



(Dale Fugier) #2

@chuck, can you look take a look a this?


(Chuck Welsh) #3

I’m looking. It will take a while to isolate the problem, but I should be able to fix it.

Chuck


(Chuck Welsh) #4

This STEP file has some really bad geometry in it. I’ve attached a surface and the curves that are supposed to trim it as one example of the problems in the fileOneSrf.3dm (35.1 KB) . You can see that the curves are not even close to the surface. A viewer like STPViewer can make this look ok, but it will not be useful. If you read the step file into Rhino4, it looks OK, too, but on closer inspection, you will see that some of the edge curves are joining surfaces that are as far as 7 units apart. Unfortunately, step files from pro-E are often this bad. I will dig deeper into this just to make sure I’m not wrong, but most likely nothing can be done without better input from pro-E.

Chuck Welsh
Robert McNeel and Associates


#5

Hi Chuck

Thanks for looking into this. I don’t really understand the inner workings of STEP files but one thing which puzzles me is why does the imported geometry show a full 360 degree sweep rather than just a sector between two angles? Also why does Rhino 4 produce a different result to Rhino 5?

So how to fix the problem? Do you have a suggestion for some other way to transfer geometry from Pro-E into Rhino which works better than the STEP file? The person producing the STEP file for me uses Pro-E and is not going to change. He couldn’t find any options in Pro-E to control the STEP file tolerance or structure. Alternatively, how easy is it for me to fix the bad beometry in the STEP file in Rhino or some other program?

Your help is much appreciated

Matthew


(Chuck Welsh) #6

Hi Matthew,

STEP files, much like any other geometry file type, represent trimmed surfaces as untrimmed base surfaces along with curves that are supposed to trim out the part that is used. This step file has as base surface, the full 360 degree sweep and some trimming curves, as shown in the file I attached in my first post. As you can see, the trimming curves are not anywhere near the surface they are supposed to trim. In Rhino4, I calculated the error in the curves and used that as the trimming tolerance. The sweep does get trimmed there and if all you want is a picture the result may be of some value. The problem is that the error tolerance in the resulting model has to be bumped up to 7 units, which is not acceptable. In Rhino5, we decided not to do that, but rather to let the trimming fail. We are working on some diagnostics to let you know when this problem happens.

I’ve asked @pascal for help on working around the problem. Hopefully he’ll have some ideas.

Chuck Welsh
Robert McNeel and Associates


(Chuck Welsh) #7

Out of curiosity, can you find out what happens when your Pro-E user tries to read the STEP file back into Pro-E? Unfortunately, I don’t have access to Pro-E here.

Thanks,
Chuck Welsh
Robert McNeel and Associates


(Pascal Golay) #8

I’m afraid I do not have much of an idea. There is a config file in ProE that governs some export settings for different formats but apart from that it looks to me like a fairly straightforward process to export from ProE as far as I can tell. I guess Ideally we could work more directly with someone who’s experiencing these problems and see if we can find out where it is going wrong. I wonder if the same objects exported to IGES are any better or worse?

-Pascal


#9

Tht’s a good idea, Chuck. I’ll get our Pro-E person to try re-import the problem STEP file to see what happens. Unfortunatately he is busy on other things for the next few days.


#10

I could also try IGES export. I do remember trying IGES format in the past and, as I recall, that was even worse than STEP export. It seems the problem is with Pro-E exporting.


#11

As a designer I often need the geometry into Rhino as fast as possible. So that can be way more important than having a HighFidelity read, with errors. So I really think the user should have the option to choose if the data should be read in as it was with V4.

And PLEASE add a tolerance override. All STEPS I exported from SolidWorks had naked edges due to this, and to me it does not matter if this is SW fault. I just want Rhino to read it in as good as possible, not all ways as mathematically perfect as possible. One thing I have learned is that in 99% of the situations Good enough is frankly Good enough :smile:

(So I don’t think you should change it, just add one or two override options)


#12

Hi Jørgen, @chuck

As a designer I often need the geometry accurately into Rhino, with all possible warnings of error prone data, for else I will get those errors down the line and I cannot get my model ready for print/production in time.

I think maintaining high fidelity by default is the best option. This is to ensure geometry being imported will comply with the file’s tolerance settings.

However, like Jørgen, I think there should be a message with an option to override that tolerance, just to let the user control all that is (reasonably) possible.

-Willem


#13

We imported the same step file back into Pro-E and the internal geometry is all messed up! I guess what you actually get depends how the STEP import function handles geometry errors. Anyway this confirms there is a problem with the Pro-E STEP export in this case. We will look into flagging it up with the ProE support team.


#14

We also tried importing the STEP file into SpaceClaim Engineer and again the internal geometry is all messed up but in a different way. The nice thing about SpaceClaim though is it can read native Pro-E files thus avoiding the STEP file stage.


#15

I absolutely agree with you Willem.
Knowing about errors are key.
At the same time one of the great things with Rhino 4 was the ability to read in STEP files other CAD packages had trouble with.


(Chuck Welsh) #16

Hi Matthew,

Thanks for checking this.

Chuck