Background goes black

Has anyone else here had the problem of their viewports going completely black for no particular reason? only way to fix it is to restart rhino. rhino is still responsive, and some non black lines are still visible, though any regular (grey) surfaces also go black.

At a guess, that sounds like either a file specific issue or a graphics card problem which could be hardware or driver related.

Can you click on About Rhinoceros from the Rhinoceros menu and then More Info. Please copy and paste the information about your system from there.

Here is the info. the machine is 2.7Ghz i7 Retina Macbook Pro.

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-09-17 (5A527)
IronPython version: 5.1.2014.701
Language: en (MacOS default)
OS X version: Version 10.9.5 (Build 13F34)


Third party kernel extensions
jp.plentycom.driver.SteerMouse (4.1.9)
com.3dconnexion.driver (10.2.0)
com.paragon-software.kext.VDMounter (36.1)
com.paragon-software.filesystems.ntfs (443.2.11)
com.paceap.kext.pacesupport.snowleopard (5.9)
org.virtualbox.kext.VBoxDrv (4.3.8)
org.virtualbox.kext.VBoxUSB (4.3.8)
org.virtualbox.kext.VBoxNetFlt (4.3.8)
org.virtualbox.kext.VBoxNetAdp (4.3.8)

Hardware information

Computer hardware
Hardware model: MacBookPro10,1
Processor: Intel Core i7-3820QM CPU @ 2.70GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 650M 1024 MB
Memory: 1024 MB
Screen size: 1440 x 900
Displays: Color LCD

USB devices
VIA Labs, Inc. : USB3.0 Hub
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller
Logitech: USB Receiver
Prolific Technology Inc.: USB-SATA Bridge

Bluetooth devices

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.26.28 310.40.55b01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

If you can still see some non-black lines in a viewport, then this likely has nothing to do with your graphics card or OpenGL drawing in general. I have this exact same McBook Pro and have never seen something like this.

Does this happen in all display modes, even wireframe? Have you changed any of the display mode settings?

Happened again yesterday. I was running in ghosted mode this time. One odd thing I picked up this time was that the blackness disappears while you are moving the camera position and reappears as soon as you stop moving. Next time it happens I’ll get a screenshot, and also try changing display modes. I havent changed any of the display mode settings (except a few days ago I changed the edge thickness from 2 to 1 (but the black viewport thing had been happening before that)

As I said, I don’t see this problem, and nobody else has been reporting this either.

You have quite a few third party kernel extensions installed. The com.paceap.kext.pacesupport.snowleopard extension has snowleopard in its name. Are you sure this is compatible with OS X Mavericks?

You might try disabling some of your other kernel extensions and see if that changes the viewport behavior.