Backface visibility

unhandled

(Johnwkrieger) #1

hi, this is my first time using this forum, I am trying Rhino 6 evaluation in Windows 7 and back faces are showing up transparent. I can flip normals but the backside is always transparent. I have looked for solutions online trying different wording, not solving problem. There appears to be a cull setting shown on some sites but I can’t find anywhere in v6. I have worked with Rhino 4 for many years, never had this problem, I created simple test geometry in Rhino 6 and imported into Rhino 4, no problems in Rhino 4. I don’t see this problem listed on this forum, am I missing something simple or is this a bug?

thanks, John


(Pascal Golay) #2

Hi John - with the viewport showing the culled backfaces active, see what that display mode is and in Options > View > Display modes > Mode name click on ‘Restore defaults’ (entries will show in blue if there are non-defaults anywhere)…

Here is the exact setting:

-Pascal


(Johnwkrieger) #3

…hi Pascal…

…thank you for your quick response…the default setting is back surface using the same settings as front, as shown in the attached image…I tried the settings as shown in the image you attached, still does not work…I am using a downloaded file with Block instances which I am not that familiar with, I thought that was causing the problem. But I noticed it was happening with all new geometry I created. I did a test with a separate file creating a simple box, same problem…I can export that file to Rhino 4 and works fine…


(Pascal Golay) #4

Hi John - can you please run SystemInfo (Help menu) and paste the results here?

thanks,

-Pascal


(Johnwkrieger) #5

here’s the text…the file size has varied between 188 to 230mb…but as mentioned before, I tried a separate file and made a simple box, same prob…am working on an HP laptop, spec attached

Rhino 6 SR3 2018-3-31 (Rhino 6, 6.3.18090.471, Git hash:master @ b32d93f452fce970e96deb46bfc68b075f06b290)

Windows 7 SP1 (Physical RAM: 5.5Gb)

AMD Radeon HD 7660G (OpenGL ver:4.2.11476 Compatibility Profile Context)

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Anti-alias mode: 4x

Mip Map Filtering: Linear

Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.

Render version: 4.2

Shading Language: 4.20

Driver Date: NA

Driver Version: NA

Maximum Texture size: 16384 x 16384

Z-Buffer depth: 24 bits

Maximum Viewport size: 16384 x 16384

Total Video Memory: 512 MB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”

C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”

C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”

C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”

C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”

C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”

C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”

C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”

C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”

C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”

C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”

C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”

C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”

C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(Johnwkrieger) #6

…here is a snapshot of image


(Pascal Golay) #7

Hi John - My guess is the graphics support is not up to it - you can try updating the driver from the AMD site

https://support.amd.com/en-us/kb-articles/Pages/Notebook-APU-Drivers.aspx

@jeff - do you have an idea?

-Pascal


(Jeff Lasor) #8

The video card should be fine… This is very odd, and the first I’ve seen this type of problem…

Does this happen in any model or just this one? What happens if you try setting different backface settings? Do they work?

Shutdown Rhino
Start Rhino
Draw a Paraboloid
Set the Perspective view to Shaded
What do you see?

You should see something like this:

If you don’t, something is obviously not right. Go into the settings for Shaded, and even though it doesn’t look like anything has been changed, push the “Restore Defaults” button anyways…and see if it clears things up.

If not, I guess we’ll need to dig further into your system and configuration.

Thanks,
-Jeff


(Johnwkrieger) #9

…I restarted Rhino, created the paraboloid, still missing backface…I did try other backface settings, nothing, so reset to default…I opened an older Rhino 4 model and same problem…Rhino 4 works fine, has for years even with files around 300 to 400mb , I don’t get this problem…I started this project importing a Solidworks file with associated block instances, thought that was the problem, but as I have done testing, appears to be happening on all geometry in Rhino 6…I can flip the normals and see the backface, but then no front surface…


(Jeff Lasor) #10

Wow, this is just really strange… I’m currently at a loss as to how this is even possible…

Using the same Paraboloid test…

What does Rendered mode look like?
What happens when you start applying materials to it?
Textures?
Does Rendered mode appear to be working? (i.e. Shadows, ground plane all present?) …

The shader that does all of the rendering has no concept of front or back faces…so this one is really a mystery at the moment… The only thing I can think of is that something further up stream in Rhino is explicitly turning backfaces off… but that’s controlled by the display mode settings, nothing else.

Do you have V5 installed? Does it work?

I need to think about this for a bit…and hopefully come up with some more things to try that might isolate what’s going on?

Very odd one here.

-Jeff


(Johnwkrieger) #11

…attached are several images, the paraboloid rendered, shader, and ray trace…the raytrace version I mapped a banana fiber material on the form, it actually shows the inside of the form but does not show the material…at this point I’ve imported the Rhino 6 file back into Rhino 4 to continue my project, which works fine. I was thinking I finally need to upgrade to 6, which is why I downloaded the trial version, but clearly need to resolve this problem…I do not have Rhino 5 but I used it at work…


(Jeff Lasor) #12

I find this troubling… The following image is missing some lines, which (to me) means that backfaces are getting drawn and affecting the depth buffer…

The only way that kind of thing can happen is if the paraboloid gets drawn first, thereby filling up the depth buffer in areas it occupies, and then the plane is drawn… The troubling part though is that the plane’s mesh is visible through the paraboloid, but its isocurves are not… Very strange!


(Jeff Lasor) #13

Hi @johnwkrieger,

My last post got me thinking…maybe it has something to do with the isocurve drawing in general…

This is a long shot, but please try UNCHECKing the “GPU Tessellation” option in the OpenGL settings page (see image).

I guess the next thing I probably need to do is start looking into getting one of these HP laptops with a AMD Radeon HD 7660G and Windows 7.

What is the exact make and model of your Laptop? A link would be preferable so I can get the detailed specs.

Thanks,
-Jeff


(Johnwkrieger) #14

…thanks Jeff for trying to help figure this out…I tried unchecking GPU tessellation, no change…I took a few more shots to maybe provide clues…

…behind door number 1…just kidding…ok, so image door 1, I selected the door and noticed the bumper shaded correctly…in image door 2, I selected bumper and everything is transparent…door 3 I deselected all, and door and bumper shaded properly over the floor, but not the grid…door 4 and Paraboloid same as door 3 then threw in a paraboloid for reference…

…seems like shading flashes on for a millisec when selecting or deselecting…does it seem it must be something with this computer as you’ve never come across this kind of problem before…??..it’s getting kinda old, maybe 5 years now, I’m starting to think I need to upgrade, is that my most likely solution…??..too bad though, I’ve done a ton of Rhino work on this machine, still works fine with Rhino 4…

…I’ll check into the computer stats…

…thanks, John


(Jeff Lasor) #15

Thanks John,

I have sort of good news… I dug up an old Radeon HD 3870 and installed it in my Win7 rig… got THE latest drivers available (which is 2013, oh dear)… Anyways, I can now see and reproduce the problem here.

I say “sort of” good news because I’m not too hopeful I’ll be able to fix this… The drivers are over 5 years old and it doesn’t look like AMD has any plans update them, in fact, I think these cards are approaching EOL with them (at least on Win7).

However, the reason I am somewhat hopeful is because you have a newer card, and it looks like it supports OpenGL 4.2 (mine only supports up to 3.3)… That’s good news, as it shows AMD is updating drivers for your card. I’m hoping if I can now figure out why this happening, I’ll be able to fix it…which I’m hoping then fixes it for you as well.

I’ll let you know how it goes…

Thanks,
-Jeff


(Nathan 'jesterKing' Letwory) #16

Could you please upload the paraboloid with the banana fiber material please? I’d like to see why it doesn’t render in Raytraced


(Jeff Lasor) #17

@nathanletwory I get pitch black results here trying to render anything. AMD Radeon HD 4870, Windows 7. Not sure what’s going on…but my guess is that the write-back to the back buffer with the results is probably failing.

-J


(Jeff Lasor) #18

It’s not looking good for these types of cards and V6… especially with only 512MB of memory on them… I’ve been hammering on this all day today, and so far have come up with nothing. Dropping back down to OpenGL 2.1 functionality (which is what V5 uses), seems to get me better results, but there are all kinds of problems elsewhere… I don’t think that type of scenario and combo was very heavily tested (obviously)…

Still digging away at it though…hoping…

-J


#19

@jeff, i would not expect that too work using cycles. Even HD7970 is not supported which is a GCN1 card. The HD4870 is 4 years older than that (I had it before the HD7970).

_
c.


(Jeff Lasor) #20

I’m using only the CPUs (of which I have 12 on this box), not the GPU… Cycles should still work and produce results regardless of GPU … The problem is that in order to “see” what’s rendering, Cycles needs to write out its results into the Rhino viewport back buffer, which requires the use of OpenGL… if that process doesn’t work properly, then you will/can never know if Cycles is working or not… but writing to the back buffer is trivial, even on the oldest, cheapest and worst of video cards, so I don’t currently have any idea why I’m seeing black atm.

-Jeff