Automatic Highlight for New Layer Naming

Is there a way to name a layer right after I click the plus button without having to double click on the layer I just made? In rhino for PC if I were to create a layer I’d immediately be able to rename it without clicking. Is there an option for this in the Mac version that I’m missing somewhere?

Hello - as far as I can see that works the same way on Mac.


It works for me in the way you describe (click plus button then immediately type layer name). I looked for an option to change this and didn’t find anything.

What version of Rhino are you running? I am running the latest Service Release Candidate Rhino 7 SR20 2022-7-6 (Rhino 7, 7.20.22187.09002).


Hmmmm. Mine has always worked for me requiring all this extra clicking which is super annoying. I am running the same version as you Kevin. Version 7 (7.20.22187.09002, 2022-07-06). Makes me thing it’s some weird option somewhere. I’ll keep looking but if anyone has any insight on this I’d love to hear it!

Hi Pascal. Could there be any reason why mine is working differently?

Hello- I do not have an idea about why it would not work the same - what mouse are you using?


It works the same if I’m using my G604 mouse or my trackpad. To confirm: when I click the plus icon on the layers panel I get a new layer but the text is not highlighted. It’s just named “Layer 01” for example. And I have to manually rename it.

I have looked several times and can’t find any settings in Rhino related to this.

Are you running any MacOS apps that might affect the function of your mouse & trackpad?

These are things I would try in order to isolate this:

  1. Disable any 3rd party plug-ins.
  2. Back up & reset Rhino settings: Rhino for Mac - Preferences [McNeel Wiki]
  3. Reload Rhino.


Hmmm. It works this way on both of my MAC computers. So, I don’t think I have any third party plug-ins that would be getting in the way.

Hello- I can see how that might be annoying. Can you please post the full results from the SystemInfo command in Rhino?


Sure. Thanks for helping! I’ve attached it here.
Systeminfo.txt (5.0 KB)

Hello- this is very much a shot in the dark but please try disabling Substance Importer in Preferences > Plug-ins page and then quit and restart Rhino - does that make any difference?


Hmmm… I just did as you said and it works the same.

Do you have any other ideas Pascal?

Hi @ckay,

I have an Intel-based Mac running Monterey and a Silicon (M1)-based Mac running Big Sur, both with Rhino 7. Neither exhibit the behavior you describe.

Do you really have a 3Dconnexion device? Have you tried unplugging it?

– Dale

Actually yes I do! Unfortunately it’s not been working either. After moving over to the M1 chip with a new computer the 3D connexion device that I’ve been using for years stopped working. I’ve been troubleshooting with their team for a while. So it’s not been plugged in and the device has been powered off. However, I still have the driver installed. Could this be the problem?