Layer naming at same time as creation


#1

Would be nice when you hit the + sign in the layer box that the new layer would have the name highlighted and be able to be changed immediately. A corollary to this would be the “change layer” dialog which allows you to create a new layer to change geometry to, but not to name it. Both these operations then require an (IMO) unnecessary second step to name the layer as we want (or maybe I haven’t figured out how to do it).

–Mitch


#2

[quote=“Helvetosaur, post:1, topic:2830, full:true”]
Would be nice when you hit the + sign in the layer box that the new layer would have the name highlighted and be able to be changed immediately. [/quote]

for me, this is already working as you describe… click the + button in the Layers panel (the one which will show up upon the Layer command)… the new layer will appear under the currently active layer and named ‘Layer 01’ (etc) but it is highlighted and you can immediately start typing a new name without the need to doubleclick the name.

unless you’re talking about this dialog in the first part of your post? because yes, i can’t name a layer via ChangeLayer either…


#3

Not working here… Click the + and start typing, all I get is the system beep honking at me… The whole layer row is highlighted, not just the name.

–Mitch


#4

that’s strange… it must be some sort of setting somewhere? (not necessarily in rhino?)

i’m on the road right now so i don’t have much time for experimenting with software… but this is what i’m getting upon clicking +


#5

Yeah, that’s how I thought it should work (like Windows) but it doesn’t… Problem with my machine? I have the latest updates to the system as well as the latest build…

–Mitch


#6

Hi Mitch,
Use + to add layer gives me opportunity to change name of layer like Jeff. As far as I can remember it has been like this for a while.

For me, if I have object(s) selected and then select change layer. It creates another layer (with +) but doesn’t select it or let me rename. I think that would be a time saver as well.


#7

OK, that’s what I was afraid of… something wrong with my install… :frowning:

I’ll look at it again tonight, see if I can see why, maybe reinstall.

–Mitch