AutoCPlane - latest WIP

I installed the latest WIP (2015-09-22) and noticed right away that I don’t get my perspective view into world top unless I go to extreme angles in viewing from above. The AutoCPlane indicator in the upper right corner sticks to left / front / right / back.

I know there are versions of the plugin that behave like that but I have been running the same version of the plugin since December. That version sticks to world top unless you get into 15º of another CPlane. It gets loaded through a startup command that reads the py script from a defined path on the C:\ drive. This has never changed but now, all of a sudden, the behavior has changed.

What’s up with that? :confused:

Hi Wim - I think I’d block the plug-ins for now and use the OneView command and see how that works for you -; also, TestStraightenView is another similar thing to fool with.


Hi Pascal. Thanks for the speedy answer!

About OneView:

Utterly useless…

About TestStraightenView, I don’t want to go into ortho view…

Is there something at all I can do to kill off the OneView behavior that is clearly getting in the way of running that python script? Delete something in the registry, perhaps?

@piac, any thoughts on options to make this more universally useful?



@wim, @pascal There have been no changes in _OneView since over two months. The change that you see cannot be directly having anything to do with _OneView. _OneView was designed since the beginning to be completely transparent unless one actually calls the command.

Other notes, one request

@stevebaer was just working this week on changes in the RhinoCommon View API. I think what you are experiencing is just some backbone change in Rhino behavior, or a bug. In general, your old script should continue to work after we learn what is breaking it.

@wim I would like to know more regarding how to make the current _OneView useful. The plug-in version that ships with Rhino 6 can be fixed to contain also your input. It was mostly shaped following opinions of a couple of users :slight_smile: ,and there is space to incorporate ideas from you, too. In the command line, when running the command for the first time, you get a list of options. You can disable the parts that you do not like.
I looked up your original answer in the February thread, but I did not understand what parts/options would be needed. Thank you for your input.

@piac, thanks for getting back on this one!

When I model in the perspective view I need to have the world CPlane to be the governing one pretty much 100% of the time. It is only when I need to create some geometry for which I in the past had to switch to 4 views and use the Right or Front view that I like the perspective view to switch to another CPlane (10º or so). But as soon as I move out of this narrow view again, the CPlane needs to go back to TOP without me having to rotate the view within 10º of the top view.

Hope that explains it better. It’s the way the original scripts used to work - but somehow no longer now…

FWIW, @stevebaer, it’s really weird the way it works now. When I launch Rhino the view - CPlane functionality will work the way it used to up until this WIP but then at some point, after rotating the view a bit here and there, it will switch to the OneView style.

I’m not exactly sure what the functionality change is that @piac is mentioning that I made. Giulio, if this is a change in the mouse callback functionality, then you just need to override the ‘other’ virtual functions to get the same behavior back.

@stevebaer It is likely one of those changes in the mouse callback functionality that made Wim’s script stop working. I’m not sure how I can help repair his script. Maybe you can offer suggestions.

In general, I hope I can get _OneView to do what @wim needs so he will not need to keep that older script up-to-date.

Sent from mobile

So, @wim, you would be fine with _OneView if only it had an option to always set back the CPlane to Top as soon as you move out of a plane ‘snap’ (stop keeping the last plane). Is that correct?

Yes, that sounds correct!

Ah, I didn’t realize this was in a script. I would need to see the script to be able to figure out how to adjust it so it works like it used to.