Auto CPlane

Started this discussion here, but maybe better to create a new topic.

Been experimenting more with AutoCPlane. It actually is interesting with certain types of objects/operations and I do like the fact that it reverts to the previous setting as soon as objects are deselected.

Questions:

  1. Will this be extended to selected multiple co-planar objects?
    I can see both advantages and disadvantages.
    Right now one can select one planar object and it sets the CPlane, and if one continues to select other objects with Shift+click, the CPlane stays, even if the other selected objects are not co-planar to the first. That could be desired behavior, or not…

  2. What is the difference between “World” and “Object”?
    Right now, if I make a world-oriented cube in Perspective (Top CPlane) and Auto CPlane is set to “Object”, if I sub-select the front face, the CPlane becomes Front-parallel. However, if Auto CPlane is set to World, I would expect it not to change, but it does the same thing as “Object”. I tried to see if I could create a difference between the two settings, but I haven’t found one so far.

Hi Mitch -
Allow me to rephrase the first question:

  1. Should the AutoCPlane stick to the first selected planar object…
  • when subsequently objects are co-planar and lie in the same plane as the first?
  • when subsequently objects are co-planar but don’t lie in the same plane as the first?
  • when subsequently objects are not co-planar to the first?

I suppose that’s why this feature is on by default - so that we can get most possible feedback on what users expect.

About question 2:

Perhaps you didn’t mean to have the word “not” in that sentence? If you try this on one of the other sides of the box, you should see a difference between the two options but it’s probably easier to see the difference with a surface that isn’t world-aligned.

World:
image

Object:
image

The AutoCPlane and the Gumball should be oriented the same when Gumball is set to “CPlane” and AutoCPlane to “World” and when Gumball is set to “Object” and AutoCPlane is set to “Object”.
-wim

Yes, I did mean ‘not’, but perhaps I’m not understanding how this is supposed to work… If I sub select the “front” face:

Object:

World:

i.e. no difference. OK, as it’s a world-aligned cube, this still corresponds with a world-aligned plane, but it certainly didn’t stay at World XY. Now, if I rotate the cube 45° around World Z, even though it’s still set at world, the plane still sets to the face. I see the same thing for both World and Object:

If I rotate the cube another 45° so that it’s really no longer aligned to any world axis - there I finally see a difference:

I get this for Object:

and this for World:

But that doesn’t seem very logical or useful to me - can you explain the logic behind this?

Hello!
Trying the new AutoCplane feature for the first time. Very nice to have, but

  1. would it be possible to avoid having to select anything first? Because features like snapping/cplane should not deal with the selection.
  2. If selecting a non-planar surface, it’s unclear to what surface normal the cplane gets aligned to. The average?
    Here’s an example of how the old autogrid feature of 3ds max works, which is pretty neat:

Thanks!

Hi Mitch - - the idea is, I believe, to be able to keep drawing (etc) on the plane as world aligned as possible and not have it be subject to the UV of the face.

-Pascal

Hi Eugen - I am not sure I follow what you are getting at… can you explain, for 5-year olds?

-Pascal

I’ll try:

To auto-place the cplane to some face, I obviously need to select the face first (In the video, I’m pressing CTRL-SHIFT-LMB when selecting a face, of course).
Is there another way to auto-place the cplane I’m not aware of?

Because, when I have to select something to place the cplane, I have to clear/‘break’ the existing selection. Breaking the selection is something that Rhino does not force unto the user easily otherwise, which is good design (Revit e.g. looses the selection far too easily and unnecessarily).

The cplane does not really automatically ‘jump’ to a face the moment i hover just over it. Intuitively I would have expected it to do so (maybe because I was used to the way this feature works in 3ds max).

Furthermore, when I select multiple faces/objects, autocplane does nothing, for obvious reasons.
That’s another reason why I’d prefer it to work just by rolling over any surface.

But maybe I’m not seeing the whole picture yet…?

Hi Eugen -

Not the Auto CPlane, no. But you can always run the CPlane command - possibly the CPlane P macro bound to an easily accessible keyboard shortcut or toolbar button?

Something that could help is that you can lock the Auto CPlane when you have set it. I’ve tied the _AutoAlignCPlane Locked EnterEnd macro to my Tab key for this purpose. If you combine that with a macro that creates a temporary named selection set, and restore that selection set when you have locked the Auto CPlane, perhaps you might get something that works for you…

We’re experimenting with mouse-over highlighting of objects. Based on that, I think that, in a simple scene, something like what you describe might work. I most realistic scenes that I’ve been testing that with, if I had to additionally make sure that my mouse was not accidently hovering over something when I create an object so that it doesn’t land on the wrong CPlane, I’d go nuts. Something like that would at least force me to work with the Auto CPlane feature turned off pretty much all of the time. As it stands now, I can work with it turned on all of the time.
-wim

An easy solution might be the opposite: put autocplane on a toggle key, roll anround the scene without it, then quickly toggle it on in the right location when needed, let it align itself as described, then draw something on it.

Hi All.

Any chance Auto CPlane could work with Clipping planes?

1 Like

That’s one of my old wishes even before AutoCplane’s inception. I previously assigned CTRL+2 to orient Cplane to a clipping plane. Works well with surfaces and meshes but not clipping plane. Something can be helpful in annotating plans and sections.

Yep, that makes sense. I opened an issue here.

1 Like

Just installed the latest v8 WIP.
Now AutoCPlane works with ClippingPlane! Thanks a lot!
The only issue I see is loosing the CPlane focus from ClippingPlane after any manipulation with it (rotate, move).
I believe it should remain while selected.

1 Like

Hi -

RH-72403 is not yet completely finished…
-wim

1 Like

In R8, when the cplane ist changed (via autocplane or by cplane command), the camera navigation now ‘matches’ the new cplane coordinate system instead of world space. This really feels kind of wonky!
Because when you rotate the viewport, then change back to e.g. world cplane, the viewport ist most probably rolled. Ugh!
I for my part would prefer the way it was in R7…
Thanks!

Hi Eugen -

It sounds like you have changed the Rhino Options -> View -> Rotate setting.

image

-wim

1 Like