Arctic mode

This is following on from the discussion that was getting a bit off topic here: Cycles render engine in RM

I’m seeing some odd artefacts with Arctic display mode in V6 WIP for Mac. These artefacts do not seem to be appearing in @Jeff 's examples in the previous thread.


Perhaps connected to the above, is the quality of Arctic display mode determined somewhat by GPU power?

The ViewCaptureToXXXX commands are 100% dependent on viewport size and resolution…meaning, if you’re capturing at Scale=1, then your results will be based on whatever Width and Height are set to…which default to the viewport’s width and height dimensions.

I mention that because Rhino’s SSAO (the type of shadows you see in Arctic mode and produced by the Skylight feature in Rendered mode), gets better and better the higher the resolution… However, it still will contain “noise”… I’m working on a 5K monitor, and so when I set Scale=2, my results are pretty large…too large to post on this forum… So using the “Preview” app on the Mac, I resize the results down by 50%, making sure that “Resample image” is CHECKed… I believe that’s why my results look smoother than yours…by resampling the image downward, I am in a sense “denoising” the results.

Note: This will probably work at any resolution (i.e. much smaller dimensions), but as I said, Rhino’s SSAO gets better at higher resolutions…I’m not sure why…this is just a personal observation…perhaps David knows why this would be.


Thanks, that’s helpful. So presumably a better GPU would improve redraw performance but may not result in a higher quality image?

Also, any thoughts on the weird stage lighting type artefacts on the screen shot I posted?

Absolutely it will…and the more GPU memory you have the better performance you will get as well…especially if you plan on capturing at high resolutions.

That’s a harder one to answer and can be subjective… My personal experience is that NVidia GPUs seem to produce better results, I don’t know why…and I’m not even sure if that’s an accurate statement…just a personal observation. The newer RTX cards are amazing, and Rhino seems to work very well with them. However, since you’re on a Mac, choosing a different GPU can be very limiting… The only real way to do it is to get an eGPU…which I have not had the time yet to test or even configure…but it’s on my todo list.


The only thing I can think of atm is that this is either pixelization due to polygon count, or perhaps depth buffer inaccuracies at further distances… The SSAO algorithm relies heavily on the depth buffer results…it’s possible that non-linear depth values are causing this. David would probably know more.

You can either try changing the meshing settings to see if more polygons help, or see if the scaling trick eliminates them.


Hey @robinp,

As a side-by-side comparison, I’ll let you see if things look any different or better between the two different platforms/GPUs…

I took your model and created a viewport that was 3072x1180 on both systems, captured the results at Scale=3, and the downsampled them by 33% using the respective programs on the different systems (“Preview” on the Mac, “PaintShop Pro” on Windows)… Now, it’s also possible that one app is doing a better/worse job at resampling the images… I used the “Smart size” option in PaintShop, and as mentioned, the “Resample image” option in Preview.


1 Like

Something else you might try playing around with is the test command “TestSSAOOptions” … Try setting the “Radius Multiplier” and “Intensity” settings to something like 4. I find on the Mac that doing that gets me closer to my Windows/NVidia results. However, that’s not what I did in the side-by-side comparison above…both systems were using the exact same settings.


1 Like

As a final test… I created a Mac result using the SSAO settings I mentioned above…and then I resampled using PaintShop on Windows. The setting of 4 may be a bit too much… So I then just did the same thing using the SSAO default settings.

In my opinion, it’s looking more like PaintShop Pro is doing the better job at resampling the results…and that the different GPUs aren’t really the determining factor here… but I’ll let you decide.

Both of these images were created on the Mac, but then copied to Windows and resampled using PaintShop Pro.


1 Like

Hi @Jeff, that’s really interesting. Would be great to see the difference when the resampling was done on the using the same app? Would then leave the only differences to be the platform and the GPU. I guess something similar could be an interesting set of studies… eg, windows using AMD vs Nvidia… that would identify potentially whether some of the difference is GPU manufacturer and what is the platform.

edit: you’ve beaten me to it on some of the above

@Jeff I’ve had a pretty good result with radius set to 1.5 and intensity to 3.5 on the Mac resulting in something looking pretty similar to your windows image. Maybe a little lighter still so maybe the intensity should be up at 4 or something

I’ve just tried a small viewport (1154x677) with a 5x scale setting. This was the result :thinking:


There’s a known issue that things can go bad when rendering arctic/skylight shadows at high resolutions. We have a fix in place for this but we can’t incorporate it yet due to a bug on Intel GPUs on Macs. It might get fixed for v7.

Do things work when you lower the 5x to, say, 3x?


I’ve just tried and had the same result. Resolution: 3462 × 1839

Edit, same at 2x as well.

Interesting. Can you provide the text from Rhino’s Help -> System Information...?

Hi, I tried quitting and reloading V6 WIP and it resolved this issue. I tried again at 5x and it crashed. I’ll try 3x again.

Another issue, I’ve noticed that Arctic mode doesn’t show surface edges despite settings in preferences. Is this expected or is not implemented yet?

Yeah, I’m basically struggling to get anything other than about a max of 2000x1200 out of view capture in Arctic mode.

@Jeff this makes upping the resolution to test dealing with the stage lighting effect impossible. I’ve tried upping the meshing resolution but it had no impact.

Edit: I have just tried custom mesh settings for the ground plane and that has improved things when combined with a file wide increased meshing setting. I think there is something in it and will fiddle around a bit more.

Sadly, I’m struggling to get anything more than around 2400x1400 out of Arctic mode. Tried various things and the failures are pretty consistently the same. Once it came out all white rather than black. Would this problem be linked to the integrated Intel GPU?

Improved stage lighting effect – if not fixed entirely – but weird error circled in red.

Screen shot showing now step in geometry as highlighted in the screen shot of the view capture image in the previous post.

@DavidEranen Is it possible for you to provide @robinp with a link to a version where you believe this should work? Sounds like @robinp would be a perfect test for it.

I’m going to load the file up on my MBP today at some point to see if I can reproduce the black object results…as of right now, I can actually get 6x working on my iMac, which is also using a 5K monitor and maximized viewport…so do the math on that one… Bottom line here, is that it seems to work so far using the latest Mac Rhino in-house build… Mac’s “Preview” app has trouble with the results in the clipboard, which I believe is because of the overall size…however, GIMP handles it just fine, so it’s obviously not a clipboard limitation problem. Using ViewCaptureToFile though, and saving it to a file and then loading it into “Preview” does seem to work…so who knows what’s really going on with “Preview” and the clipboard at this point.

Anyways, @robinp getting high resolution output is unfortunately going to require massive amounts of memory (both main memory and GPU memory) by Rhino in order to do the things it does…so any limiting hardware in this is area is going to most likely also limit the capabilities and possibilities. Rhino tries its best to get around things like this by iterating through a series of smaller output and then “tiling” them together…but if you’re using the clipboard, the final result still must be the entire image in memory… So if you’re using ViewCaptureToClipboard, and not getting the correct results, I would try ViewCaptureToFile and see if it helps at all… As mentioned, I will try to reproduce the “blackness” issue on my MacBook Pro today (it’s very limited by hardware and memory), and then see if I can determine the cause. It’s possible that our in-house builds currently work…so I’m hoping David can get you a version to test out (if you’re willing to try not-so-stable versions of Rhino for the time being).

@DavidEranen, if I can determine which version should work, then I’ll probably just post a link to it here…but if this is something in a private branch that you’re working on, then you’ll need to do the leg work here.


Sorry, I’ve just seen this. I think I must have missed it in my flurry of posts. I’ll have a look tomorrow when I’m at my computer again.