Help with Arctic mode please

unhandled
(Boyd) #1

I am using Rhino 6 on a Mac. I was rendering lately and now my arctic mode is displaying with harsh flat surfaces. Restoring to defaults didn’t change anything. I have deleted the rhino preferences file and started over, but that didn’t fix it. Where is the setting so I can have the soft Arctic display mode back? Last time this happened, it was because I had changed the ambient light color in the rhino render panel. Putting it back to black doesn’t fix the problem.

Thank you,
Michelle

(John Brock) #2

I just tried Arctic in the just updated WIP and it’s working fine here.
I understand you use the restore defaults. That’s good.
Have your Quit and restarted the WIP?
Have you restarted your Mac?
Does a new, simple file like a Box display property?

(Boyd) #3

Thank you. All good ideas, I hadn’t restarted the computer. None of them restore the regular arctic mode, still flat grey surfaces on a white background.

Michelle

(Boyd) #4

I think I changed the shadows, or lighting settings and I don’t know how to get them back.

(John Brock) #5

Open all five tabs in Arctic, and click on the Restore Defaults in each one.
Lighting should be Ambient Occlusion.

(Boyd) #6

I see that the lighting is Ambient Occlusion, but I am still getting the flat grey surfaces.

(David Eränen) #7

Hi @boyd,

Could you paste the text from Help -> System Information... here?

Also, a screen shot of the problem would be helpful.

-David

(Boyd) #8

Here is the system info:
Rhino 6 SR9 2018-9-28 (Rhino 6, 6.9.18271.20591, Git hash:master @ 4cf7435f08f51c972347c8558d28355cfc0471ca)

Licence type: Educational, build 2018-09-28

License details: Cloud Zoo. In use by: michelle ()

Windows 10.0 SR0.0 or greater (Physical RAM: 2Gb)

Machine name: MICHELLEBOYD01D

Parallels using Intel Iris Pro OpenGL Engine (OpenGL ver:2.1 INTEL-10.36.23)

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Anti-alias mode: 4x

Mip Map Filtering: Linear

Anisotropic Filtering Mode: Height

Vendor Name: Parallels and Intel Inc.

Render version: 2.1

Shading Language: 1.20

Driver Date: NA

Driver Version: NA

Maximum Texture size: 16384 x 16384

Z-Buffer depth: 24 bits

Maximum Viewport size: 16384 x 16384

Total Video Memory: 1036970 KB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.9.18271.20591

C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”

C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”

C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”

C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”

C:\Program Files\Rhino 6\Plug-ins\RhinoCAM 2019 for R6\RhinoCAM 2019 For Rhino6.0.rhp “RhinoCAM 2019 - The cutting edge CAM plug-in for Rhino 6.0 from MecSoft Corporation”

C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”

C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”

C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”

C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.9.18271.20591

C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”

C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”

C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”

C:\Program Files\Rhino 6\Plug-ins\RhinoCAM 2019 for R6\RhinoArt1FileExporter For Rhino6.0.rhp “RhinoArt1FileExporter”

C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.9.18271.20591

C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.9.18271.20591

C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”

C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”

C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

(David Eränen) #9

Did you always use Parallels, or did the problem start after?

(Boyd) #10

I have always used parallels

(P1r4t3b0y) #11

Hi @boyd,

Judging from your system report, it seems like you are not using Rhino for Mac, but Rhino 6 for Windows in virtualisation (Parallels, VMWare, etc.), which in my experience is a bad idea, since the virtual environment already eats up a good portion of your computer performance, and your main OS (e.g. macOS) also runs in the background. The performance needed by those processes isn’t available to Rhino anymore.

Furthermore, Rhino 6 for Windows has a memory recommendation of 8GB or more. Your virtual environment that Windows is run in, seems to only have access to 2GB, which is probably too little RAM.
Also, only using a discrete GPU, like your Intel Iris Pro, for live viewport rendering in Arctic mode is probably not very efficient either, and might be where your display problems stem from?

If you need a stable version of Rhino 6, for whatever reason, simply run it in Bootcamp under Windows. However, if a stable Rhino 5 is good enough for you, run it natively in macOS. For Arctic mode, you can install RhinoWIP 6 natively on macOS, but it’s a beta and not very polished yet.

Artic mode is simply a representation of your viewport in ambient occlusion, which literally every render engine can do. You seem to have V-Ray, so this could be an alternative.

(Boyd) #13

My issue is that arctic mode displayed properly until I rendered using Rhino render for a project. I just want it to work the way it did last week.

(Wim Dekeyser) #15

Hi Boyd - is there any reason why you are running 6.9? I would at least get on the latest version and see if that changes anything.

(Boyd) #16

I really don’t want to upgrade three weeks before the end of the semester. plus if it worked before I started rendering, but not after. That tells me that it was something to do with me changing the render settings that made it stop working.

The last time this happened, I changed the ambient color back to black and that fixed everything.

The one thing I have not done is be particular about the order for restarting everything. I plan to quit Rhino, delete the rhino preferences file, turn off Parallels, and restart my computer, I just haven’t had time. I have done all of those things separately, but not all together.

Here is an image of what arctic mode looked like on my computer on April 4.

(Boyd) #17

quitting Rhino and parallels, deleting the preferences file (although this threw an error message), and restarting my computer did not give me arctic mode.

(David Eränen) #18

@boyd,

Something has changed that is making Rhino downgrade OpenGL to version 2.1. Arctic mode requires version 3.3.

The first thing I would recommend that you do is install the latest Rhino 6 version. You’re using Service Release 9, but the latest is Service Release 13. Please go to Help -> Check for Updates... and then click the “Check Now…” link. Download the file and install. Any difference?

-David

(Boyd) #19

Thanks. I am not going to change my software three weeks before the end of the semester. I have too much to do to introduce that wildcard. It would be nice to figure out what changed and fix it without having to reinstall.

When I look at the advanced options in the Display Options panel, for OpenGL I have:
Anisotropic Mode: 3
Antialiasing Mode: 2
Line Smoothing: True
Major Version: 2 (I changed this to 3 with no effect)
MaxLevel: 45
MipMapMode: 2
RegenBufferonHardwareSwap: True
UseCore Profile: False
UseHardwareDriver: True
UseTesselationShaders: True
Use Texture Compression: False
Wire Thickness Scale: 1

Will changing any of those help?

Thanks!

#20

Computers do background updates all the time and many without notification. As you said you restored to default, then most likely something in your Mac/Windows system changed. You can try restoring your system back to a previous date, as described here.

https://kb.parallels.com/en/122841

Or you can try updating Rhino, it won’t take more than a coffee break.

(P1r4t3b0y) #21

I’ve just remember that Windows 10 updates somehow used to overwrite my GPU drivers in Bootcamp, which made my dedicated GPU stop working, until I reinstalled the latest driver from the website of the manufacturer. I don’t know if that’s the case in Parallels, but it won’t take long to check.