Arctic Display Mode

unhandled

#1

Hi guys,

Whenever I open a model in Rhino WIP, one of the Display modes I love is Arctic. However, when I select it, I inevitably get a Wireframe mode. To get it to look right, I have to go to Preferences>Display Modes>Arctic and restore defaults. This works until I open the WIP again, and it has gone back to wireframe.

I attribute this to fooling around with the Arctic toggles about 4 WIPs ago, the problem is every time I update the WIP, the problem reoccurs - I restore the default settings, and go round the circle again…

Thoughts?

Nick


Display panel locked on wireframe and problem display artic (update, resolved by canceling the Artic mode from the Rhino 5 settings)
(John Brock) #2

I suspect there is a problem with your plist where these are stored.
See if this helps you get things reset:
https://wiki.mcneel.com/rhino/mac/resetprefs

Any luck?


#3

Thanks, that seems to have worked!


#4

Actually, it hasn’t. After a few hours I went back and restarted Rhino WIP. The problem persists.


(Dan Belcher) #5

Are you still experiencing this problem in the latest RhinoWIP? If so, can you please post the results of SystemInfo along with a copy of your preferences file ExportPreferences? Thanks.


#6

same issue here, have to go and click restore to default to get arctic mode to show. Also the the problem of the view drop down menu and r/h side panel don’t match up, i.e I can choose Pen from the view drop down menu, but in the r/h display panel it will show as wireframe


#7

Hi Dan,
Yes, the problem still exists, and the problem noted by milezee - I would say that it is definitely the same as the other problem you linked to here:

Display panel locked on wireframe and problem display artic (update, resolved by canceling the Artic mode from the Rhino 5 settings)

My system info files are attached, thanks for taking a look.
Nick

RhinoWIP System Info 22-November.txt (9.9 KB)
RhinoWIP Preferences 22-November.plist (260.4 KB)


#8

Hi again, following up on this, I’ve noticed that hiding the right-hand sidebar changes the settings of a display mode, for instance if I am in shaded mode with curves switched off, when I hide the sidebar the curves will switch back on. When I unhide the sidebar, the display window shows me the wireframe settings, regardless of which display mode I am in.

thanks,

Nick


(Pascal Golay) #9

Hi Nick - thanks for this, it certainly sounds like some wires are crossed - I’ll see if I can reproduce it here.

-Pascal


#10

Arctic mode still showing as wireframe in todays latest WIP. Have to go into preferences and click default to make it active