Any idea what's wrong


#1

Hi there,
I have been going through a weird and strange problem which i have been not able to find a solution. It is really making my work worse and more time consuming.
The main problem is some models are showing correctly like some part of it is torn away like thing!, also the edge doesn’t appear and by which sometime it is not possible to fillet it etc. I have attached the screenshot of the problem so you all can understand the problem


#2

hi Rahul, its not sure how to help you here the best would be you posted one of those little chips in an extra file. just drag and drop it into the reply field.

without the file my first guess would be that the curves you used to create those extrusion might not be fully ok, for instance partial duplicated curves. but you can first try to explode and rejoin see if that helps.


#3

Hi RichardZ,
The the thing is that i have tried it on another pc and i was able to make the same thing without the above problem and i tried to find out if any is missing in my computer but is there in this pc, again not problem there also. Still clueless!:thinking:


#4

are you using mac or windows? i believe there was a general problem with one of the mac releases with inverted surface normals which led to obscure effects like here. it got recently fixed so maybe update to the last version, otherwise try to post the file.


#5

Iam using windows, both tested pc were windows one.


(David Cockey) #6

@Rahul - How far from the origin are your models? What units are you using? How large are the models? What is your absolute tolerance?

Strange display and other problems can occur when models are very long distances, such as millions of units from the origin, and/or when the tolerance is very small compared to the size of the model. Absolute tolerance is available in DocumentProperties > Units.


#7

Iam using mm and the current absolute tolerance is 0.001 relative and angle tolerance are 1. Some thing wrong?.


(David Cockey) #8

@Rahul - Those are reasonable tolerances unless you model is very, very big.

How large is your model? You can use BoundingBox to find the size of a box which fits around it.

How far is your model from the origin? Just pick any point on the model and tell us what the coordinates of that point are.


#9

that was my first thought either but the upper screenshot shows the grid, so i guess its not that…


(David Cockey) #10

[quote=“RichardZ, post:9, topic:46388”]
that was my first thought either but the upper screenshot shows the grid, so i guess its not that…
[/quote]You are probably correct unless the CPlane has been relocated.


(David Cockey) #11

What graphics hardware does your PC have? How recent are the drivers? Also what version and SR of Rhino? (Go to Help in the top line > About Rhinoceros)


(Pascal Golay) #12

Hi Rahul - I don’t see a file - as Richard suggested, it will be much easier to sort out if you can post a file with one of these objects. My guess of the moment is that there is an extra surface someplace in that object.

-Pascal


#13

Yeah sure attached the filestest.3dm (2.1 MB)


(Pascal Golay) #14

Hi Rahul - please select those objects and run DivideAlongCreases on them. That should sort it out. Please also run the CreaseSplitting command and make sure that is set to ‘Yes’.

-Pascal


#15

@pascal Thanks pascal for that valuable info i think the problem i had with the main band and the u shaped cutters gone but still the v shaped cutters is not solved which is the main part. 70% solved


#16

The graphics card i use is geforce gtx 960 and drivers are up to date with last update on today morning!


(Pascal Golay) #17

Hi Rahul - and selecting that object and running DivideAlongCreases does not fix it?

-Pascal


#18

Yeah the options “split at tangents” and “split at kinks” should be set to yes right?


(Pascal Golay) #19

Hi Rahul - try both but I think on these you only need to split kinks. But again, make sure CreaseSplitting is Yes, so that these objects are not created to begin with.

-Pascal


#20

done the running DivideAlongCreases with only split at kinks on yes but after that when tried for CreaseSplitting it said to select the object then i went to select the object but couldn’t able to select the object!..what may be the problem?