Non-manifold edges

unhandled

#1

Would you please tell me the procedures to fix this problem on this model? Is it possible?


#2

@JWW, hard do judge from the first image without the having the real geometry.

The second image looks like the render mesh setting is too coarse. You can change that globally for all objects under:

_Options > Document Properties > Mesh

_
c.


#3

Sorry about that. Here’s the model. TestPath.3dm (4.6 MB)


#4

@JWW, i guess it’s a tolerance issue. Because the model is so small compared to the unit system (inches) your absolute tolerance and mesh settings have to be set finer.

Apart from this there are some duplicated surfaces. I’ve just deleted all surfaces and then tried to extrude the curves, then rhino complained that it finds self intersections. In order to prevent that i’ve lowered the absolute tolerance to 0.0001 inches under:

_Options > Document Properties > Units

This is required since you have very small curves measuring only 0.0056322 inches. But your tolerance was 0.01 units. The tolerance is better set to be 1/10 of the smallest feature in your model, or even smaller.

You can now just extrude and snap to the point i’ve left to get a closed object.

TestPath.3dm (114.4 KB)
_
c.


#5

Thanks for taking the time to solve my problem, it’s appreciated.

-JW:


#6

Is this also a tolerance issue? If not would you explain the procedure to fix it?

Thanks,
-JW:Trailer blind hold down.3dm (676.8 KB)


#7

Hi @JWW, no it is just a naked edge. You can extract the surface(s) to fix it like shown below:

The commands i used are: _ExtractSrf, _Untrim, _Trim, _Join
_
c.


#8

Thanks for the perfectly clear video and commands used. After I did that (if I executed it correctly) I ran SelOpenPolysrf and got this?

Trailer blind hold down.3dm (353.4 KB)

-JW:


#9

… so I need to join those surfaces, correct?


#10

Hi @JWW,

yes and make sure when you use _ExtractSrf to not extract a copy so the option should read _Copy=No

_
c.


#11

… is there a way to globally join the meshes? It appears when i exploded it that the entire model exploded.


#12

@JWW, you do not need to explode it. The _ExtractSrf command is on the right mouse button command of the explode icon. If you look at my video each click i do issues a colored circle around the mouse pointer. When the circle is red i clicked with left mouse button, when it is blue i clicked with the right mouse button.

_
c.


#13

Thanks very much. Everything worked out fine.

Regards,
-JW:


#14

Looks like I’m having a bad day. I was saving this R6 file as a .STL (like usual) and it says it’s not compatible for rapid prototyping. I don’t see anything wrong with it? What am I missing?

MM-11 eyepiece dovetail adapter for18mm DiMAGE.3dm (559.5 KB)

-JW:

PS: BTW, the previous file “above” you helped with printed great, thanks again.


#15

It’s hard to say without the STL file you created. I’ll attach one created from your file using the default setting of 0.01 in binary format. If i import that back into RH6 it flags it as a good mesh but that could be wrong. What software complains reading your STL file ?

JWW.stl (848.2 KB)

_
c.


#16

This is the .STL file viewed in Rhino. It looks the same in my slicer.


#17

I tried to slice my STL it in Cura. It did not complain. Maybe try different mesh settings. Also re-import and use _Check command on the STL or post the one you’ve written.

Btw. if i use _Show in your last rhino file, a part comes up which is open. It is on the floor of your left image.
_
c.


#18

… sorry about that, I forgot to post the .STL.

MM-11 eyepiece dovetail adapter for18mm DiMAGE.stl (1.1 MB)


#19

The _show did the trick. I would of never figured that out. Whatever that entity was I deleted it.

Thanks again,
-JW:


#20

Looks like I jumped the gun on that one. There’s still a solid or something in the bore or on the bottom.

CheckCommand.txt (1.9 KB)