Any idea what's wrong

DivideAlongCreases asks for a selection, CreaseSplitting does not, it is a setting that allows or prevents creased/kinked objects to be created.


but strange thing is that, i tried to mesh that object and then repaired that mesh then it had cleared!. But as i need only in polysurface, that is of no use.

yup!!! i think it has solved!!! done the CreaseSplitting and then again create the thin cutters and now i think it has gone!!

@pascal is this due to the CreaseSplitting option set to no before it?. But now and then this problem happens but when i run CreaseSplitting then that will go. Dont this solves permanently without running the command everytime?

Hi Rahul - by default CreaseSplitting is set to Yes, and new surface that have creases are split into polysurfaces before being created and added ti the file. Sometimes this gets set to No, and you get things like what you had - single surfaces that have hard corners or kinks. These can be useful sometimes but are not the default way to go and they frequently do not display correctly as you saw.

So - setting CreaseSplitting to yes should avoid the problem in the future.


1 Like

This problem in seams so shading wrong. Explode geometry, move seam to other edge with (Adjust closed surface seam tool) and join geometry back in solid.