FurtherFillet Issue

I’m getting this wierd result.

Fillet Issue.3dm (791.2 KB)

No such problems here.
Fillet Issue-wd.3dm (468.2 KB)

So then to make it work you extracted some of the surfaces?

No. It works just as fine without extracting them. But since that was all that was relevant in your file, I first extracted them and hid the rest.

Well then that’s a real mystery. I wonder if there’s some setting that’s causing this. Would you mind taking a look at a larger portion of the model?Fillet Issue.3dm.zip (319.4 KB)

What do you mean with a larger portion?
That model is not the same anymore - the top flat surface you want to fillet is wider overall and the corners are already filleted. Is this the model you actually had problems with - no the one you sent first?

At any rate, I don’t know what you did to that model but that top surface is not in a good shape - it covers the entire opening but is not shaded:

If you extract and delete that surface and run DupBorder on it, you should get two 2 curves but there are 4. Two are tiny edges somewhere else in the model and can be ignored - for this problem (but you should fix those as well).
Selecting the two top curves and running PlanarSurface on them results in one surface. Then making a fillet on that edge around the hole isn’t a problem around here.
Fillet Issue (2)-wd.3dm (870.8 KB)

Hi Wim,
I tried to get back to you earlier but the site was not letting me. I apologize for the mistake. I copy and paste the parts of the model in question into a new document to keep the file small. I’d missed the inner bezel when I did so. As too the strangeness of the face over the opening, I’d thought I’d deealt with that yesterday but apparently not.

So I’ve returned to this part and extracted the top surface, duped the edges of inner and outter and planar surfed for a new face. It worked! Thanks. How were you able to so quickly diagnose the problem?

And then there’s this thing with the edges showing a tiney naked area. Is there an easy fix for such tiny issues?

NakedThing.3dm.zip (972.6 KB)

To find out what is wrong with surfaces it’s not a bad idea to have a look at the structure of the surfaces. I put the display in wireframe mode and saw that I needed to turn on the Show surface isocurve object property on to see the isocurves. [Is that a deliberate thing you do, turning that property off? I’ve noticed this before]. With isocurves showing, it was clear right away that there were isocurves going across the hole in the object.

In this case it was surprisingly easy. I extracted the two surfaces bordering on each of those and then joined them again. That was enough to get rid of the naked edge. Do you remember how you made those surfaces? The document tolerances are at 0.001 and the naked edges were about the same size. I have a feeling that somewhere in the modelling process you changed the tolerances. I would advice strongly against that.

Well yes, I’ve turned off the isocurves as at times they’re rather distracting. I’ll start making a habit of checking things over in x-ray.

I’ve never changed any default settings as to tolerances. I do on occasion get a message that tolerance had to be doubled to complete an boolean operation. I figure if the app allows it, it must be okay.