AMD - Viewport glitches when clipping planes are on

I have an HP ZBOOK Laptop with an AMD Radeon Pro WX3200 Graphics.

I get strange glitches when I enable clipping planes (check screenshot).

I have updated the drivers and also checked and unchecked tessellation.

When i switch to the integrated Intel GPU all is ok.

Hi - Please run the Rhino SystemInfo command and post the result here.

Ok, here it is.

Hybrid graphics system.
Primary display: Intel® UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 10-7-2019 (M-D-Y).
Primary OpenGL: AMD Radeon Pro WX3200 Graphics (AMD) Memory: 4GB, Driver date: 4-15-2019 (M-D-Y). OpenGL Ver: 4.6.13559 Compatibility Profile Context FireGL 26.20.11002.1001

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 4-15-2019
Driver Version: 26.20.11002.1001
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi - I take it that you are running into this issue also with just a simple box and a clipping plane, or is it more file-specific than that?

It looks like there is a newer driver available for that Radeon Pro, could you give that one a try?

Hello @wim , thank you for your reply. Unfortunately I have the latest drivers and also yes, it happens even with a simple box.

I am having big problem with this issue. I would be very grateful if you could fix it.

I cannot see why it is happening, this video card is supposed to be a professional card made for CAD software.

I saw the same on my testmachine after updating win 10, the drivers for the wx7100 and rhino… all up to date at the same time so I don’t know what caused it, but it smells like driver errors.

Hi @andreasor81 -

I can’t tell if that means that you updated the drivers since my last message…

Also, are you seeing glitches when in the Wireframe display mode as well?

Hello @wim, yes I have updated with the latest drivers.

Also there are no glitches in wireframe mde.

By the way, it seems that _viewportproperties doesn’t do anything!

It won’t work… Maybe its connected to the problem…

It probably does, it opens up the properties panel. If it is already visible the command appears to be doing nothing.

Ah ok, yes you are right.

However i am still having problems with this glitch.

I have an AMD processor, but it’s things like this topic that makes me wary of AMD video cards, though they often have better compute performance, because AMD doesn’t hobble them as much as nVidia.

If I stop seeing stuff like this, certainly I will reconsider AMD for my next video card purchase.

Hi - the glitch is very similar to something that we have seen on a very specific configuration of Mac hardware. We have just solved that particular issue and so I was wondering if you would want to test if this also fixes the problem you are having.

Here is a link to the build-of-the-day of the Rhino 7 WIP:

Thank you for sharing! For me it also useful

Thank you @wim, I have tested and now it is working properly. However their is still a strange behaviour that still remains. The wire frame of the mesh is not clipped properly.

Take a look to the image below:

I hope you can do something about that as well.

Are you going to create an update for Rhino 6.0 as well? Or do I have to use Rhino 7 WIP from now on?

Hi - good to hear that something is working better now.

Are you saying that it is now only for mesh objects that the clipping plane is causing this behavior?
Could you post a simple file that shows this on your system?

The issue was fixed for both Rhino 6 and 7 but you’ll have to wait for a 6.23 release candidate to see that in Rhino 6.

Hello @wim,

sorry for the late reply but ts very busy at work these days.
test.3dm (2.4 MB)
I believe the problem appears in all surfaces, only that it is more obvious on mesh, because there is a lot of it and also it has strange pointy edges.

So here is an example file. I hope you will find it useful.

If you manage to correct this issue as well, you could try to include also this one in 6.23.

Good morning @wim, I hope you didn’t have any problem opening the file.

Any news about it?

Hi @andreasor81 - no, I didn’t have any problems opening that file, which, in a way is bad because I couldn’t reproduce the issue. The developer hasn’t been in but I’ll put this in a YouTrack report so that it can be followed up.

A few more questions:

  • Which display modes do you see this effect in? Are those factory-default modes? (you can tell if they have been modified by looking in Rhino Options > View > Display Modes. If the list in the left-hand column has anything in blue, that means that that mode has been modified).
  • Could you post a screenshot of a scene with a simple NURBS box that is clipped?


Hello again @wim,

it only appears on the Shaded View in fact. I guess its because of the AMD graphics card.

Thank you for the support.

By the way, I also installed the Service Release Candidate for Rhino 6 and I have the same issue.