Rhino on Bootcamp Clipping Plane Glitch

Hi all,

I have just got a new MacBook Pro 16 with Radeon 5600m (hbm2) and am having an issue with the clipping plane with any version of Rhino on Bootcamp. Please see the below image - one taken from Rhino Mac 7 Beta, works fine, and the other from Rhino Win 7 Beta, clipping plane doesn’t work (the same result from Rhino 6 as well).

Rhino 7 Beta Mac
on Rhino Mac 7 Beta

Rhino 7 Beta Win (Bootcamp)

I know someone in the forum suggested to turn GPU acceleration off on advanced option, and in terms of the clipping plane issue, it resolves the issue, but with serious performance loss. Apparently, they are using the same hardware, does this have something to do with AMD’s driver or Rhino display pipeline? Any idea?

Thanks,

W

Hello - make sure to update the Windows side display drivers to the latest.

Please run the SystemInfo command in Rhino and copy/paste the results here.

-Pascal

Hi Pascal,

I have double-checked the display driver up to date. And below is the system info.

Rhino 7 SR0 2020-10-6 (Rhino 7 BETA, 7.0.20280.13133, Git hash:master @ 20cf6f2e18fea3ddc63ececb3c03e30ed0775462)
License type: Educational, build 2020-10-06
License details: Cloud Zoo
Expires on: 2020-11-20

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Non-hybrid graphics.
Primary display and OpenGL: AMD Radeon Pro 5600M (AMD) Memory: 8GB, Driver date: 4-20-2020 (M-D-Y). OpenGL Ver: 4.6.13587 Compatibility Profile Context FireGL 19.50.32.01 26.20.15032.1001

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 4-20-2020
Driver Version: 26.20.15032.1001
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8176 MB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7 WIP\Plug-ins\Commands.rhp “Commands” 7.0.20280.13133
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7 WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20280.13133
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20280.13133
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20280.13133
C:\Program Files\Rhino 7 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20280.13133
C:\Program Files\Rhino 7 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7 WIP\Plug-ins\Displacement.rhp “Displacement”

Hello - the next thing to try is to disable Vray in Options > PLug-ins page, and then close and reopen Rhino - does that make any difference?

-Pascal

Hi Pascal,

As you suggested, disabled Vray and reopen rhino, and it is the same as below.

Hm - I still think it is worth looking at the drivers - for example, this looks promising:
https://www.amd.com/en/support/kb/release-notes/apple-boot-camp

-Pascal

Just in case, here is the system info of Rhino 6, which has the same issue on the bootcamp.

Rhino 6 SR29 2020-8-25 (Rhino 6, 6.29.20238.11501, Git hash:master @ 06b936ae4e8c289ecccfd6b5ee9bacccc60eded1)
License type: Educational, build 2020-08-25
License details: Cloud Zoo. In use by: Woojae Sung ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: KS-MBP-WIN

Non-hybrid graphics.
Primary display and OpenGL: AMD Radeon Pro 5600M (AMD) Memory: 8GB, Driver date: 4-20-2020 (M-D-Y). OpenGL Ver: 4.6.13587 Compatibility Profile Context FireGL 19.50.32.01 26.20.15032.1001

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 4-20-2020
Driver Version: 26.20.15032.1001
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8176 MB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.29.20238.11501
C:\Users\woojs\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino6.Plugin” 0.0.20237.1315
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Just installed the driver, which i believe is the same version as it says “repair”, but i did it anyways - and it didn’t help…

On both 6 and 7, safe mode works fine with the clipping planes…

Oh, I guess it is same thing to turn off opengl…
Any idea? Thanks, W

Hello - my only thought is to look at the AMD bootcamp driver linked above - is it somewhat more recent than your current one and appears to be for this exact case, if I am reading it right, of using bootcamp.

-Pascal

I did installed the version in the link, but it is the same. Anyother suggestions? Thanks!
W

For those of you having the same issue, I found this 3rd party driver do its job.

1 Like