Outlines of objects do not clip in Rhino 6.0, Rhino WIP 7.0 is ok - AMD GPU

In fact, I have posted in the past some glitches regarding viewport realtime rendering with an AMD Radeon Pro card. I have been asked to post the second glitch it in a different post so here it is.

It seems that the clipping plane does not clip the outlines of the objects unless they are fully clipped.

However, I have recently downloaded the latest versions of Rhino 6.0 (6.25.20105.13371) and Rhino WIP 7.0 (7.0.20105.12495) and I was surprised to see that for Rhino 7.0 doesn’t appear to have this issue anymore.

Some screenshots below:

Original Model

Rhino 6 - Shaded

Rhino 6 - Wireframe

Rhino 7 - Shaded

Maybe you could correct this bug in Rhino 6.0 as well?

Hi - could you please also post that 3dm file and your updated SystemInfo data?
-wim

Hello @wim,

There was no test file. However, I prepared one for you.

Below my system info:

Hybrid graphics system.
Primary display: Intel(R) UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 1-9-2020 (M-D-Y).
Primary OpenGL: AMD Radeon Pro WX3200 Graphics (AMD) Memory: 4GB, Driver date: 11-14-2019 (M-D-Y). OpenGL Ver: 4.6.13560 Compatibility Profile Context FireGL 26.20.11030.16003

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: Height
  
  Vendor Name: ATI Technologies Inc.
  Render version: 4.6
  Shading Language: 4.60
  Driver Date: 11-14-2019
  Driver Version: 26.20.11030.16003
  Maximum Texture size: 16384 x 16384
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 16384 x 16384
  Total Video Memory: 4 GB

Rhino plugins
  C:\Program Files\Rhino 6\Plug-ins\Commands.rhp	"Commands"	6.26.20118.17211
  C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp	"WebBrowser"	
  C:\Program Files\Rhino 6\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp	"RhinoScript"	
  C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp	"IdleProcessor"	
  C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp	"Rhino Render"	
  C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	6.26.20118.17211
  C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
  C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp	"Alerter"	
  C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	6.26.20118.17211
  C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	6.26.20118.17211
  C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp	"Displacement"

cliptest.3dm (263.4 KB)

Any findings on this one?

Hey @wim,
I have downloaded the new update of Rhino 6.0 and the problem persists.

I am surprised I don’t see this problem in Rhino 7.0 WIP but still in Rhino 6.0 it is not fixed.

Hi -

For quite some time now, fixes are mainly implemented in Rhino 7 and only in rare and specific cases should you expect changes in Rhino 6.

That said, In a recent reply, @Holo mentioned that updating the drivers for his AMD GPU fixed the clipping issue on his system. Have you updated your drivers lately?

Also, what does it look like when you draw NURBS boxes and not extrusion objects?
-wim

I hope the new drivers help for you, but I see that AMD still has opengl curve drawing uglyness in Rhino, and that is such a shame.

Nobody expects new features to be added to SR’s but fixing bread and butter tools for dedicated hardware should be prioritized on the official build IMO. Especially when it’s well known that Beta versions can not / should not be used for production by the majority of the users. So please see if you can implement some v7 fixes in v6.

2 Likes

Hello @wim.

Nurb boxes look the same. Even Isocurves don’t clip.

Updating drivers didn’t fix the issue.

I understand your point but then why do you make updates for Rhino 6.0? And does this mean previous versions of Rhino are obsolete after the new version comes out? I wasn’t aware of that. I am really surprised!

Fixing existing issues seems to be really important. Not to mention that you can already perform a comparison between the codes. I agree with @Holo

Couldn’t agree more with this. These are things that should work in V6, and by not adding fixes like these ones to V6, we are being forced to upgrade to V7 as soon as it comes out, which I’m sure it’s not your intention but it’s the reality.

This doesn’t look like a fix that was intentionally made in V7 and kept out of V6. Driver bugs are finicky and very difficult to reproduce. My guess is that this was an unintentional fix that happened as a side effect from making other changes in the code.

Maybe I’m mistaken though; @wim do you know of a YT issue that specifically fixed this in V7?

1 Like

@stevebaer - No, I don’t know of a V7 fix that specifically targeted behavior like this.
As far as I know, we only ever saw something that looked a bit like this but that was for very specific hardware on the Mac and was fixed in Rhino 6.
-wim

Thanks, that’s what I figured as well. @andreasor81 this looks like a machine specific driver bug. Try turning off GPU tessellation in Rhino’s OpenGL options page. There’s a chance that drawing wires using an alternate technique will remedy the situation.

1 Like

Hi @stevebaer and @wim,

i had a similar problem like the OP when i updated my AMD driver in April. It started after i upgraded to SR24. Since i could not work like this i rolled back to my old driver (using a system restore point) which fixed the issue for breps and extrusions. However, with meshes i still have a problem with clipping and my old driver, the mesh wireframe is not clipped:

Please also note my report about clipping planes and dimension objects. It is not behaving as expected.

btw. the reason i picked the old driver is because the curves are not degraded. AA worked much better a year ago for me.

_
c.

1 Like

Hello everyone,

@stevebaer, I have tried what you proposed. I have tried even forcing several 3D options from the AMD driver
@stevebaer, I am not sure what kind of Graphics card you have. I have a mobile Radeon Pro WX3200.

@wim, by the way, you have already contributed to correcting a glitch in the graphics in my other post.


Rhino 7 had this glitch as well and it was corrected, together with the problem of the edges after my post. Rhino 6 had the glitch corrected, but not the problem of the edges.

Anyway, it seems I will have to get a Workbook with an Nvidia Graphics Card next time.

Poor AMD…

Hi Clement -
Are you seeing any of this on Rhino 7?
Can you post your SystemInfo please?
-wim

Hi @wim, sorry i don’t have it yet here. Atached is my SystemInfo using the old driver.

SystemInfo.txt (2.1 KB)

_
c.