Clipping Plane Not Working

Hi, am Josh and am trying to use the clipping plane but it does not cut through the solid object, it only shows a solid line on the surface of the object as I move the clipping plane. This is unrelated problem but I noticed when using chrome picture in picture, the small window that is supposed to pop up and let you view the video out of chrome shows up as a black box with no video, but when I uninstalled my graphics card software the picture to picture mode worked perfectly. So i though maybe the same problem is affecting my rhino model. I decided to uninstall my graphics card software, restarted my pc and made a solid object the ran the clipping plane command and this time it worked. I could see the clipping plane cut the solid box as i moved it up and down. I again reinstalled the graphics card software restarted my pc and ran the command in rhino and I had the problem that am dealing with at the moment. I have a AMD 7 3700x cpu with a ASUS Asrock B450m motherboard and a AMD Radeon RX 5700 XT graphics card. Please help.

Hi Josh - please run the Rhino SystemInfo command and post the result here.

Rhino 6 SR21 2019-12-17 (Rhino 6, 6.21.19351.09141, Git hash:master @ 4d373f64ffb55e3a8d607d9618590728d86fb1e9)
License type: Evaluation, build 2019-12-17
License details: Cloud Zoo. In use by: Joshua Mwatibo ()
Expires on: 2020-02-23

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: JOSHTIBO

Non-hybrid graphics.
Primary display and OpenGL: AMD Radeon RX 5700 XT (AMD) Memory: 8GB, Driver date: 1-13-2020 (M-D-Y). OpenGL Ver: 4.6.13586 Compatibility Profile Context 20.1.2 26.20.15011.10003

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 1-13-2020
Driver Version: 26.20.15011.10003
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8176 MB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”

Hi Josh - thanks for that information. That sure looks like it should work fine but obviously there’s something going on with the drivers for that card.
Time to turn to bigger brains - @jeff - do you perhaps have a comparable card with a driver that is known to be good or any other ideas around this issue?

As a temporary test, please run Rhino Options > Advanced
Filter the list using “UseHardwareDriver”.
Set it to False.
Close and restart Rhino.
Expect Rhino to be slow. This is only a test.
With the driver disabled, do the cutting planes work as expected?

Thanks for trying Wim

So, I set “UseHardwareDriver” to false, closed and restarted Rhino and the clipping plane works as expected, John.

Am guessing the command disables my graphics card, because I did notice that the command I just ran looks like when I uninstalled my graphics card software and the clipping plane worked as expected.

Unfortunately, that’s a pretty clear indication the problem with the clipping planes is an issue with the Radeon drivers.

Maybe @jeff or @stevebaer will have some ideas.

Thanks for the help John, atleast now I know how to disable my graphics card without having to restart my pc, instead of uninstalling the driver and installing it all over again.

Hopefully, either AMD will fix their drivers, or Jeff and Steve come up with some dark magic that works-around the driver limitations.

We’ll see how it goes, I hope Jeff and Steve work something up, fingers crossed.

Okay so, a friend of mine has a Radeon RX590, and is running the same software that I am running (Radeon Adrenalin 2020) and he doesn’t seen to be having the same problem that I am having with the clipping plane. Another friend of mine has tried explaining to me what the problem is with my computer, I didn’t understand him quiet well but what I got from him was that my computer was processing graphics but not off of my graphics card.

When I open Rhino from the desktop shortcut that I created Rhino seems to run smoothly but the clipping plane does not work as expected, but when I open Rhino from my graphics card software, Rhino runs as if I just ran the “UseHardwareDriver” command (it is very pixeleted,) and the clipping plane works as expected.

Am sorry if this is confusing, it is to me but I hope it will help come up with a solution.

Hey Josh.

I am currently having the exact same issue and I too have the AMD Radeon RX 5700 XT. I have been talking to Tech support over the past couple of days and they basically said the same thing.

"It means the video card driver is misbehaving… you may try uninstalling your driver and installing an older driver, try from january of last year.

AMD is a bit of a pain point for us as they don’t update their drivers as comprehensively as nvidia does. This may take some trial and error on your point to find a driver that is stable and displays your clipping planes correctly.

I’d suggest posting on your forum to see if you can find someone with a similar setup to your and see what driver they are using. That may cut down on the amount of searching you’ll have to do to find a good driver. "

This is the response I got. I tried installing an older driver at

The earliest driver they seem to have is from July, which I installed but the issue still remains.

This has been a pain for me lately and I hope there’s a solution soon.


Thanks for the help Kevin.