Amd radeon hd 8670m open gl issue


#1

Hey there,

I just installed rhino on my new lenovo notebook with a radeon hd 8670m card. when I am in the 4 viewport mode and I drawing in one of the viewports, the 4 viewports start flickering which makes working impossible. when I turn off hardware accelerated mode, everything works ok, so I suppose it has something to do with open gl (redraw scene turned on and off but no changes). I updated my cards driver to the latest, but no changes also. (Rhino5 newest SR)

any ideas?

thanks christian


Windows 8.1 compatibility
4 Viewports in 5.0
(Brian James) #2

Hi Christian,

Can you try these settings?

Also, is this happening with all models or one in particular?


(Brian James) #3

This driver also is more recent and I see your series in the release notes. Is this not right for your OS?
http://support.amd.com/en-us/download/desktop?os=Windows+7+-+64


#4

hello christian,

does it work any better if you set Antialiasing to “None” under the Appearance Settings ? (with accelerated hardware modes enabled"). Also make shure Antialiasing is set to “application controlled” in your catalyst control center or display driver dialog.

c.


#5

no success so far…

@brianj: tried your suggested settings. still the same. tried your catalyst version same there. and yes the flickering appears in all models…
@clement: also tried setting aa to none, no luck there. I attatched a screenshot of my catalyst settings (which I tried changing without success, sorry only in german, but all set to “use application settings”)

anything else I could try?

thank you very much for your help!

ch


#6

I am having the same issue and no solution here either.

see post here.


#7

yes, change the Antialising method from Supersampling to Multi-Sampling and turn off openGL tripple buffering in catalyst control center. Also try changing morphologic filter to off. Those settings seem to differ from the driver defaults. Does that help ?

c.


Rhino Video Card Problems?
#8

thanks clement, but still no success… :frowning:

any settings i could try on the rhino side?


#9

hi christian,

another try would be to set the driver defaults in catalyst control center first, then enable only accelerated hardware mode in Rhino. Do not enable Antialiasing on boths sides.

I`m using an older driver with HD7970, below are my slightly tweaked settings in the driver defined as custom profile and the rhino settings. I´m sorry if this is all trial and error.

You mentioned the display flickers only if you draw something. Do you get the flickering right after you´ve envoked the tool, eg. the _Line command? What happens if you start the _Line command and just hover with your mouse over one of the four viewports without drawing ?

If you maximize one view, or close other views does it still flicker ? Is this problem present in all display modes eg. Wireframe, Rendered etc ?

btw. make changes in CatalystControlCenter while Rhino is not running. If you could record the flickering this might help the developers to pin down the problem further.

c.


4 Viewports in 5.0
#10

still no success with other catalyst settings…
the flickering is present in all display modes, but ONLY when I run 4 viewports. I uploaded a screencast to youtube where you can see my problem…

thanks christian


#11

hi christian,

from your video, this looks like a buffering problem which gets triggered just by invoking a command. Can you repeat what djnelson75 encountered in this thread, eg. does the problem go away if you use the standard 3-Viewport layout instead of 4-Viewport layout ? Does it come back if you then eg. use the command _SplitViewportHorizontal to create a fourth viewport ?

There seem to be other users facing similar problems. Hopefully @jeff the display developer can sheed some light.

c.


#12

When I startup 5.0 in safe mode everything seems to work fine, but graphic cards are not plugged in of course. After closing safe mode and starting up regular 5.0 everything seems to work fine.

So maybe this is the solution. Perhaps it has to do with order of loading plugins??

Perhaps it works for you too.

Rijndert


#13

tried it, but no success…still trying to find a solution ;(


(Willem Derks) #14

Hi,

There seems to be something broken with AMD cards, I and others have similar issues reported here:

I’m confused as to why apparently no one from McNeel can at least confirm the issues.
Sorry to bump this again @pascal but could we have a status update on this please.

-Willem


(Jeff Lasor) #15

We can’t confirm them because we don’t have any machines with the card(s) exhibiting the problem. It’s one thing to know about a problem, but it’s something entirely different when it comes to fixing it without even knowing what the problem is. I understand your frustration, but until I can personally sit down on a machine that contains Rhino’s source code and reproduce the problem, then speculating is the only course of action…which I don’t like doing…but as of right now, I can’t even do that. I have no idea why the number of views would have any impact on the way things function…it makes no sense whatsoever. The only thing I can say based on the current feedback is that this is definitely an OpenGL driver related issue since turning off acceleration seems to make things work. SafeMode works because OpenGL is completely disabled altogether (which is NOT the same as turning off acceleration).

At this point I’m not sure what path to take…other than buying a laptop with the exact configuration and hope that it shows the same problem (which of course there is no guarantee that it will)… But McNeel cannot run out and start buying every laptop configuration every time someone has some kind of display issue. Desktop cards are a different story since I can get them directly from AMD, but laptops are something entirely different. For now, I would continue to check AMD’s site for any kind of driver update (they release them once a month), and since this is a FirePro, I believe you can get the updates directly from AMD and not the laptop manufacturer…most of the time manufacturers ship laptops with at least 6 month old drivers due to their pre-install and disk-image creation processes.

A last ditch effort would be to start playing around with the settings in the CCC to see if they produce any different results… but that can be tedious since the changes do NOT affect currently running processes, which means you have to shutdown Rhino, make changes in the CCC, and then restart Rhino and test. This most likely will not produce anything useful…but it has uncovered problems in the past.

I’d like to start compiling a list of all affected hardware… So please, those of you having these issues with AMD cards, please list your EXACT machine make, model, OS (bit version too),and video card. I’ve got an email pending with AMD about this but no information yet.

Thanks again for your patience and feedback, and again I understand your frustration and apologize for no solution thus far.

-Jeff


4 View Visualization Problem on new Samsung notebook
(Jeff Lasor) #16

I just realized that Willem’s issue is with a Radeon not a FirePro…so I guess ANY AMD card that is showing these types of issues, I’d like to hear about it… Please specify Laptop/PC, Make and Model, OS, and Video Card/Chip… so that I can forward the info to AMD’s dev team. If they can see the problem on their end, then most likely they’ll be able to tell me exactly how to fix it…or probably they’ll fix it.

Thanks,
-Jeff


(Jeff Lasor) #17

Here’s what AMD just wanted me to check with you guys…

"The important thing is to get their Driver packaging version-- They can find it by Right clicking on their desktop and clicking on AMD Control Center and clicking on Information/Software. They have gotten the latest driver from Dell.com which to us will most likely be on older driver vs. what we post on amd.com. However, they may be using the latest from amd.com, but would really like to confirm by getting this info: (see red boxes in screenshot). Second, If they are using switchable graphics, they can disable it to see if they results are different. "

See image…


#18

hey jeff thanks for your help!

here s my setup:

Lenovo Thinkpad S531
Windows 7 Professional (x64) Build 7601
Intel HD Graphics 4000
AMD Radeon HD 8670M


(Willem Derks) #19

Hi Jeff,

Many thanks for your answer. I’m deep in a project right now (on my old laptop due to the new one not being fully setup yet) but during the weekend I’ll try to report back with this info.

-Willem


#20

Here are my machine setup


Rhino Video Card Problems?