All red in latest WiP

In the latest WiP I see most customizations for surface appearance in Shaded broken. Apart from that, all newly created surfaces are created in red colour. At least Ghosted and Wireframe seem to show the same issue.

Shaded Viewmode is reset to default values.

Random surfaces are created. (from curves + primitives) Wireframe previews (at creation time) show the intended Layer colour, but the finalized object overrides Layer colour and per object colours and displays red. Probably due to this I fail setting further options: Custom backface colour, edge + naked edge colours > this all does nothing. Only colour reduction for Edges seems to work.

Does anyone else see this too?
Did I accidentally check a global switch which isn’t set in Display Modes?

Hi hifred - I do not see this happening here… If you have not, I guess closing and restarting Rhino might be a thing to do… Nothing comes to mind that would cause this but I could be missing one. You’re sure the vp is in fact set to use that default Shaded mode and not a modified one, right?

-Pascal

I was afraid so :o)

This install is totally vanilla, there’s not even custom display modes present. I have of course restarted the WiP (several times actually). Still the same. I attach the ini but it should be in the default state…

cheers, Holger

Shaded.zip (2.4 KB)

Hi Holger, I have been unable to make this happen… your exported mode works fine here as it did yesterday in a previous build… I just cannot think of what setting to look at if this is a default mode, which it is… - the object when created has the expected display setting and layer, correct?

-Pascal

Hi Pascal,
sorry for the late reply. Here’s a little clip which shows the issue a bit clearer than the gif.
I used a fresh file (the default Small Objects Millimeters template).

To me, for example, it shows me the red object during the fillet operation. I think it’s a visual anomaly … (I set everything by default).


Also, as I pointed out in another post, nothing in the panel “custom attribute settings” works: the top preview (the sphere) is not updated by just modifying a parameter. If you drag the “faceted shadow”, the preview does not update.
If I hit the “Use Object Color Display” box, I can not choose any color (it works in the opposite direction).

All very strange.

Hi Holger - wow, crazy… @stevebaer, @jeff - does either of you have an idea what’s up here? See Holger’s clip above from a few days ago . (Holger, I was out of the office for a few days )

-Pascal

Strange… is this still happening in the WIP released a couple days ago?

Yes Steve, always the same problems … The settings are default, the video card drivers are updated … but Rhino returns the same defects (those described above).

I think there are some problems in the “custom object attribute settings” panel. It does not update the preview as any parameter changes, and the color of the object (for example, during the fillet operation) depends on the color you choose by unchecking this box “Use Object Color Display”.

All very strange …

Let’s start with the most basic situation like Holger described. If you have your display settings all reset to default and create a sphere in shaded mode, does it show up red?

No, it is gray (as by default).
But if I run a fillet, for example, during the operation, the object assumes the color chosen in this parameter of the custom object settings panel



Looking at your screenshot image it appears you have many non-default view modes.

I just changed the color of the isocurve and edges … I will try to set everything in default

Hi Steve, Pascal,
I have just downloaded WiP 6.0.17297.9141 and repeated what I did in that clip.
Yes, I still get a proper colour preview and a red final surface.

Also any existing models show completely red, regardless of Layer- or Object colour. Here’s a screenshot of an old (V5) furniture model…The few areas which appear darker in the image are locked items.

I think I see what is going on. Make sure the the checkbox in the following image is checked.

@jeff is this a bug? Seems like at least we should be resetting this value when we reset defaults.

I guess it’s a bug. The preview image is not updated in the panel “Custom object attributes settings” and, strangely, when you select “use object’s display color” you can not select a color (it works in contrast, in fact, if you deselect then you can choose a color).
You will need to adjust everything …

That box is checked. But the default material doesn’t look as it should.
My default material has a slightly more greenish grey (see Layer Manager) but clearly isn’t red…

My first thought was that the Emap-Image might be causing this, but I haven’t touched it and if I turn the Emap off the shading remains red.

C:\Users\Holger\Dropbox\Screenpresso\2017-10-27_22h55_02.jpg

Can you send me your settings file? You should be able to find it at
%appdata%\McNeel\Rhinoceros\6.0\settings\settings-Scheme__Default.xml

Thanks