Bug - Locked color of curves

(6.0.17303.23521, 2017-10-30)
YT: RH-42357

Curves always adhere to the locked color set under Rhino Options > Appearance > Colors > Object display > Locked objects.

When you try to override this color in a specific display mode, surfaces will take on the override color but curves will not.

Default Rhino Options > View > Display Modes > Wireframe > Objects > Locked Objects settings:

Result in viewport:
(where red and green curves are NOT locked).

Override settings:

Result in viewport:

All objects unlocked (and grid turned off…):

I see it, thanks for creating the bug report.

Hi Steve,
Just FWIW, in the current (6.1.17309.1121, 2017-11-05) I cannot get curves to show up in the viewports in any display mode. Also, in Wireframe mode, surfaces do not show up.

I believe @jeff was working on this over the weekend

@stevebaer I don’t think so… look at the date of his build… It’s Sunday…My fix was in by Saturday’s build… It’s possible I may have broken this, and/or made things worse. … Ugh. But so far I’m not seeing any bad behavior here.

@wim I’m using the exact same version of the WIP as you and I can see curves and surfaces just fine… To be sure, what happens if you reset your display modes to their defaults? (Save them first, because I’m probably going to want them, or at least a couple of them if things clear up).

Also, what is your Video and System configuration?


In that case, don’t worry too much about this for now. My laptop has been installing updates every time I shutdown - something clearly is not working on that end. Not anywhere near the machine at the moment but I’ll check when I get to it. Factory default wireframe mode, btw…

@jeff, @stevebaer,
I’ve now updated my GPU drivers to the latest version and Windows now starts and shuts down without problems.

After a reboot, I installed the latest daily (6.1.17310.15361, 2017-11-06) but Rhino doesn’t find information on driver version and date. I’ve now also uninstalled and reinstalled Rhino to no avail. Tips or Tricks? (Other than turning off GPU Tesselation…)


Rhino 6 SR1 2017-11-6 (Rhino WIP, 6.1.17310.15361, Git hash:master @ 8b487c6094a1f645b8997bb60de6fd630238821b)

Windows 7 SP1 (Physical RAM: 31Gb)

Quadro K3100M/PCIe/SSE2 (OpenGL ver:4.3.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.3
Shading Language: 4.30 NVIDIA via Cg compiler
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 128 MB

FWIW, Rhino 5 now displays the following upon launch:

Wow…obviously this shouldn’t be happening…and that is legacy code from V5 that should probably get removed…

Here’s what I would try before going any further…and there is a method to my madness here… Most of the time when Rhino fails to collect driver information, it’s because multiple configs exist (over time), and it gets confused…V6 does a lot better job at and my guess is that dialog is using the older method…Anyways…I have found that a clean full uninstall of the drivers clears this up…

  1. Uninstall your video driver completely (i.e. don’t just “update” it)
  2. Reboot
  3. Install the latest driver you recently downloaded
  4. Reboot
  5. See what happens.

…I will be removing that dialog in the next release…thanks for alert us to it.



Looking through the code, it looks like if you click “Later”, the dialog will (should) never show again… At least that will get you into Rhino…at which point, driver version isn’t really important…but I would like to see what Rhino’s OpenGL page says.


just to clarify:

By that I meant that when I launch Rhino 5, I get that dialog box. But, hey, if it helped you getting rid of that in RH6… :wink:

At any rate - and I know that RH5 is behind us - I found it strange that Rhino (5) would point to a much older driver when I had just updated to the newest available.

I assume this is RH6 BETA and before I do anything with the drivers (unless this is moot anyway because I didn’t get the dialog in RH6)…

I’ll start the process of cleaning up the drivers now.


I’m confused then… At one point we were talking about curves not displaying in the current V6 WIP …and now you’re talking about V5 and this driver message…

  1. Does this message come up in V6?
  2. Can you get Rhino V6 up and running?
  3. Does Rhino V6 display curves correctly/as expected for you?

…those are the items I thought we were discussing here. Anything happening in V5 is beyond my reach at the moment…sorry.





I’ll leave anything v5 out of this now…

Does Rhino V6 display curves at all? The locked curve color bug was simply a logic error in our code and has nothing to do with GPU drivers.

A lot of (re-)installing later… Rhino now displays curves again.

Drive date and versions are still reported as NA but the OpenGL version shows the driver version.

RH-42357 is fixed in the latest BETA

FWIW I have been seeing the NA string for some time now too.

1 Like

Hmmmm… I’m seeing it too here. What’s strange is that my local builds work…it’s only the Beta that seems to be floundering with the driver date and version.

I’ll figure it out.

Thanks @nathanletwory for bringing this to my attention.


The driver info should be working again in the latest build of the day.