My Viewports are all Black

I am new to Rhino. I started two weeks ago for school, and I was working on a project when one day my viewports are all black. The viewports themselves show up as the 4 of them are still there, just I can’t see my work anymore. I don’t know how to fix this and I had a project due today for college that is now going to be late so I don’t know what to do. I installed rhino 7 literally two weeks ago and it has worked fine this whole time until now.

I saw other people posting their system info when I was trying to troubleshoot it myself, so here it is if it helps.

Rhino 7 SR14 2022-1-10 (Rhino 7, 7.14.22010.17001, Git hash:master @ d8a2d020be8cb487bfc091316ef32170cfc7eddb)
License type: Evaluation, build 2022-01-10
License details: Cloud Zoo
Expires on: 2022-04-12

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 7.9Gb)

Computer platform: LAPTOP - Unplugged [86% battery remaining]

Standard graphics configuration.
Primary display and OpenGL: Intel(R) HD Graphics 5500 (Intel) Memory: 1GB, Driver date: 11-10-2016 (M-D-Y). OpenGL Ver: 4.4.0 - Build
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.4 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.4
Shading Language: 4.40 - Build
Driver Date: 11-10-2016
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hello Wesley,
Welcome to our community, as you can see, your Graphics drivers are 6 years old, please update to the latest driver and this will likely solve your problem.
let me know if this didn’t help

ok, how do I update them?

Because your Intel GPU is not only very old, but never did meet Rhino’s minimum system requirements, you should consider replacing your computer with one that does.

You may find to get Rhino running at all, you’ll likely need to go into Options > View > OpenGL, and reduce the OpenGL level Rhino is asking the card to support.