Accidentally changing a viewport to perspective, is there a fix?

When I’m doing a lot of subobject selection, I occasionally end up accidentally doing a combination of ctrl, shift and right click that will shift my top, right or front viewport to perspective view.

This seems to happen more in the WIP but that could just be because I’m doing a lot of SubD stuff that requires a lot of subobject selection.

I know I can just click on the viewport menu and change the view back to “top” for example.

But is there a setting that will make a 2d viewport not respond to a 3d rotate command from the mouse? It’d be great if I could just block it from happening at all, rather than having to undo it every time it happens.

Why are you using Ctrl+Shift+RIGHT click? Normally subobject selection is Ctrl+Shift+Left click…

I think what’s happening is that I’m keeping the ctrl and shift keys down while trying to pan, not using the wrong mouse button to select.

It’s still be nice to be able to lock viewports in 2d.

Well, Rhino viewports are always 3D… The Front, Side etc. viewports are just parallel projection views of the 3D objects.

That being said, I agree 100% that it would be nice to have the option to not knock a parallel view off-axis by using Ctrl+Shift+RMB. We simply need a setting to disable this action in Options>Views. @pascal


Yeah, minor frustration, and yeah I could learn not to do it, and yeah, it seems like it’d be pretty easy to disable.

There are a number of display and viewport and panel related actions that one can do accidentally and that can be annoying to undo.

Since I’ve been using Rhino for a while, I know how to undo them and it’s just a minor annoyance, but for new users it’s a common source of confusion.

How many “where did my layers panel go?!” posts does this forum get? Would things like that happen less if, for instance, we could lock docked windows individually, as opposed to globally, and there were some defaults that we could recommend new users start with?

Yes 2D views must fixed and locked

1 Like

You’ld think the ‘Always pan parallel views’ option would do this, or a sub-option of this …

Yeah, looked at this one as well but it will not prevent rotation with Ctrl+Shift, only blocks the RMB-drag rotation and always pans non-ortho views. Perhaps another option in that area could be added to disable rotation of parallel views altogether. I don’t think currently it is possible in Rhino.

Mitch, all - the end result would be that you could never skew a parallel vp using keyboard shortcuts, but you could still use the commands to do that… correct?


1 Like

Exactly… :+1:t2:

If you extensively use ctrl+shift for subobject selection, when you’re moving fast it’s pretty easy to accidentally do this.

1 Like

Exactly. I typically don’t accidentally skew viewports very often. Occasionally it’ll happen. But testing SubD is making it happen much more often, because most selection in that context is subobjects.