'_4View issue

When using ('_4View), the viewports are not rearranged immediately, but must be moved once with a right-click to reset. Therefore, it is not possible to capture a neatly arranged screen because the viewport is moved once.
Currently, Rhino 7 is the latest version.

Try to click the button two times, I think that should reset the views to default.

Right click once on the 4View button. That launches the following macro:

'_4View ZEA

i.e. a 4View plus a ZoomAllExtents in all viewports.

'_4View ZEA tool knows of course. However, since I intend to capture the 4 sides, top, front, side, and perspective should be displayed as a grid aligned with each other at the same camera magnification as the image attached now.

The '_4View ZEA tool is not suitable for capturing or printing 4 sides because Top, Front, Side, and Perspective are all displayed at different camera magnifications.

Anyone can easily find a workaround that works by using other similar methods.
I’m asking because I want the tool to work in its own way without bugs.

You want to activate “Toggle linked views” or for a one shot, “Synchronize views”


The 4View command is not intended for doing what you want; therefore this is not a ‘bug’.

Did you see the video right? Nothing happens when I left-click on the tool, isn’t it a bug?
I will attach the video again, so take a look at the video below.
In 5.0, it immediately resets the viewport to normal. In 7, it does not respond to pressing the button, and the reset is completed when you press another tool or go to the rendering view wireframe view. In the previous version of 7, it worked normally, but after several updates, this phenomenon occurred, so I will leave an inquiry. It’s very disappointing that it’s not a bug, right?

P.S I feel it every time I report a bug, but why do most of the answers always suggest an inconvenient way to circumvent the bug rather than fix the underlying bug?

Hi -

Do you remember which version worked normally?

I can’t remember the exact release version, but this happened a month or two ago. Nearby genuine user acquaintances also experience the same problem.

Are you set up to receive only new releases, or release candidates as well? Or do you manually control which updates to receive?

Release candidates are not used and always kept up to date when new updates are made. This problem occurred in the official version, so I updated to the candidate release, but the same occurs.

4View is broken here as well, at least some of the time. I’ll see what I can find out - I thought this had been fixed.

Still open -
RH-67440 4View: redraw lags


1 Like

thank you! I hope it gets resolved quickly.

RH-67440 is fixed in Rhino 7 Service Release 19

Thank you very much