4-view Bug - 5D143w and earlier

4-view bug still exists in 5D143w. Not just with existing files.

  1. Create new file and object
  2. Switch to a single view and close/save in single view
  3. Open file and choose 4-view

You should get the uneven divide in the image below.

Seems the issue happens when a file is saved in single window, reopened, then choose 4-view.

Hi Richard - I see this, thanks.



This bug should be fixed in the latest RhinoWIP. Please let us know if you still see this behavior.

Thanks again for reporting this!

This bug seems back in 5E199w. Seen on two separate Macs. Not sure the trigger? But once the disease kicks in, hard to cure.

If I quit Rhino, relaunch, and create a new doc, the new doc comes back like this:

Odd. I can’t reproduce this in the latest RhinoWIP. Perhaps something about my hardware configuration. If you can figure out what the steps are to reproduce this one reliably, please let us know.

Odd indeed. Can’t reproduce reliably, sorry, but here’s a new clue just discovered, if such means anything?

Was induced by a file been working on for months.

Issue would happen when clicking the 4-view icon. Even after save, quit, relaunch.

Instead of using the 4-view icon, tried typing the 4View command. Command divides evenly as expected!

Made change, saved file and quit. Thereafter, both 4-view icon and 4View command divides evenly as expected.

Is there any logical reason why 4-view icon and 4View command might produce different results???

i had this recently either, it comes and goes and i could not track down any reason other than using fullscreen then closing rhino and when opening again this occurs, something in this direction. using a laptop with an external screen set to main screen.

These sort of details are usually critical to figuring out what is going on. That’s why we are often obsessive about seeing or getting exact descriptions of each step in gross detail.

Unfortunately, that detail didn’t work for me to reproduce the issue on my end, I’m afraid.

None that I can think of.

Same here. I wonder if this is clouding my ability to see this issue. Testing again without my external display connected…nope, same result: working as expected.

@ec2638 Can you please send your current preferences my way? (ExportPreferences)