3D Connexion not loading

When I start Rhino my 3D Connexion device doesn’t work. I have to close it down and restart Rhino - then it magically springs to life. This has happened since I updated to the latest version of 3DxWare (10.6.2).

Has anyone else experienced this annoyance or even better found a solution? I assume the plug in isn’t loading properly or something first time.

@Markus - do you have an idea?

-Pascal

MisterB,

I have had some problems with my wireless 3DConnexion SpaceMouse after installing the latest drivers. Unfortunately I haven’t been able to pin down a specific pattern. Sometimes I lose all functionality, and sometimes just one of the axis is not working. Unplugging an replacing the USB wireless dongle sometimes helps.

The strange thing is that the 3DConnexion demo applications always work even when Rhino doesn’t.

I know that I haven’t supplied enough information for anyone to attempt a fix (I can’t even tell if the problem is with McNeel or 3DConnexion software), but I just thought I’d let you know that you are not alone.

John

I noticed that I got a message about the 3D Connexion plug in being blocked during one restart - haven’t seen it since. There doesn’t seem to be a fixed pattern - sometimes one restart gets it going other times it takes more. Very odd.

Thanks for chipping in, John. It’s good to know that mine isn’t the only one misbehaving.

My device is a wired Spacemouse Pro. I’ve fiddled with the plug in settings in Rhino but there doesn’t seem to be a obvious cause. I have managed to get it going eventually so it hasn’t been too much hassle yet but it would be nice if a fix could be found.

@pascal Unfortunately I am out of the office until the beginning of September. I will get back to you when I can try to reproduce.

-Markus

Just an update on this - a minor annoyance has become a major pain.

This morning no matter how many times I restarted Rhino my 3D Connexion device would not work. I found a comment on the 3D Connexion forum saying that the latest driver (which I’d stupidly installed when prompted) had been withdrawn, which was confirmed when I checked.

So I remove that driver, download and the one I had previously and reinstall it. That still doesn’t work, I keep getting messages from Windows saying its stopped working and no matter how I try I can’t get it set up to work in Rhino as I like. It does work on occasion, but then freezes.

OK, half the morning gone and still not resolved. Next option, download and install the oldest driver I can find. Still isn’t working. Something in that latest driver seems to have fundamentally broken my set up.

Where does the 3D Connexion Rhino plug in comes from? Is it installed as part of Rhino? Reinstalling it is the only other thing I can think to try.

I have done a repair installation of Rhino but that hasn’t helped. Every time I try to configure the Spacemouse settings with Rhino open I get an error message from Windows saying the 3DWare driver has stopped, and it no longer works. Pretty frustrating waste of a day.

I’m absolutely sure this is 3D Connexion’s fault, not McNeel’s. I guess I should go and vent over on their forum!

Hello - I’m sorry you’re having such a bad time with this - I am unable to reproduce the problem here - it seems to just work as expected. Do you have V5, 6, or possibly the 7 WIP as well, installed? If 6, can you run SystemInfo in Rhino and post the results?

-Pascal

Hi Pascal, I think I might’ve found a solution. I stumbled across a comment on the 3D Connexion forum linking to instructions about cleaning configuration files on Windows. I thought I’d give it a try and so far it seems to be working. I guess the latest drivers (the ones now withdrawn) must’ve corrupted these files. All very annoying as I’ve lost most of a working day messing about with it, but not McNeel’s fault. I think this one is on 3D Connexion. I shall be more wary of allowing their drivers to update in future.

Thanks for your help Pascal, much appreciated.

OK, good deal! thanks for the update.

-Pascal