Cant get 3d connexion to work in rhino

rhino
bug
unhandled

#1

Hello,

I’ve been using a 3D connexion for a while now and I just plugged it back into my laptop and it doesn’t work any more. I’ve tried Rhino 5 and 6 but absolutely nothing. It doesn’t appear to be the 3D connexion since this is working perfectly in MODO. Any suggestions would be great appreciated. Many thanks, Paleblue


(Nathan 'jesterKing' Letwory) #2

Is the 3Dconnexxion 3D Mouse plug-in loaded? Check in Tools » Options » Plug-ins


#3

yes, it says loaded and enabled.


#4

but still not working :frowning:


(Nathan 'jesterKing' Letwory) #5

You do have the driver installed for the device?


#6

Yes, I’ve reinstalled the driver which has worked, but it still seems a bit temperamental upon loading. It appears that sometimes the macros fail to load although the connexion tab is present. I’m just rebooting a couple of times until it works, seems a bit odd but currently manageable. Thanks for your help :slightly_smiling_face:


(Nathan 'jesterKing' Letwory) #7

I would test more, but someone took my SpacePilot Pro without my permission (read: stole). Sad face.


#8

Rhino update has made it fail yet again!!!
Please help!

Now the Rhino options say “Use the 3Dconnexion Properties in the 3Dxware driver to configure”
There isn’t an option for Rhino in there any more.

I’m becoming concerned of Updating now since every time it stops something from working, wasting too much time…
Please any advice. I’m desperate


#9

Updated drivers… Still nothing working


(Wim Dekeyser) #10

Is this a matter of configuration ‘only’, and, if so, have you tried to use the configuration in the 3Dxware driver?


#11

Rhino 6 is not availible in the configation in the 3Dxware driver.


#12

is there a quck way of reverting back to previous version? I have a really tight deadline and it feeling like working with one hand tied behind my back. I have to use a wacom so don’t have the view controls of a standard mouse.


#13

It’s not a config issue, there is nothing working with the 3Dconnexion whilst in Rhino. No inputs at all.
Absolutely fine in all other apps


(Nathan 'jesterKing' Letwory) #14

And the plug-in is still loaded?

The latest Rhino 6SR4 needs an updated 3Dconnexion driver:

Let us know if that is enough for you to get it work.


#15

Thanks,

A life saver :slight_smile:

It appears to be working. I am using the earlier 3Dconnexion which normally works best with the original DVD drivers. It appears that this 3Dconnexion update has looked into these issues.
Thanks again.


(Nathan 'jesterKing' Letwory) #16

Good to hear you can continue your work :slight_smile: