3D Connexion Mouse Plugin Disappeared!

Updated my Spacemouse driver and now not working or recognised in latest Rhino 6.

Spacemouse compact is one year old and working fine in other applications.

Attempted a clean install. No joy. Tried older drivers. No joy.

The 3DConnexion option in Rhino settings has gone too. Even with a complete uninstall and fresh driver install Rhino fails to detect the Spacemouse.

Spacemouse works ok in other software and in 3Dconnexion control panel test display.

Any suggestions or help would be much appreciated. Thanks

In Options > Plug-ins, is the 3Dconnexion driver enabled and loaded?

Thanks John

I did try that but to no avail as it wasn’t even showing as a plugin even after completely uninstalling and reinstalling the driver.

I have fixed it now. Heres what I did.

The problem I had was on my desktop PC so I grabbed my laptop and installed a fresh copy of Rhino to it.
Plugged in my 3D SpaceMouse Compact.
Installed the most recent 3D Connexion driver.
Was recognised and worked great on my laptop.
So then went into the Rhino 6 plugin folder and copied the 3dxrhino.rhp file to the same folder on my desktop PC.