2D DXF files are very large and curved with many points

Hello. I have a problem with the size of the 2d dxf file exported by the SDExportDownload component.

It exports the file with many dots which prevents the laser machine from reading the file and making the cut.

Each point is a new direction reading for the machine, requiring more time to process the shapediver files.

In the definition I created there is an internalized source file that is cut as the person changes the length and height of a sheet of metal.

The source file is in dxf format and has a smaller size than the laser machine can read, but the one generated by the shapediver it cannot.


The source file in dxf is 1.3mb but the file exported by the shapediver is 25.5mb. Also considering the size of the file this ends up affecting the maximum size of the outputs.

In the source file the curves are regions and in the exported file the curves are polylines.

1 - Is there any configuration of the SDExportDownload component that can decrease the number of points?

2 - Is there anything you can do in the definition so that the number of points is less without changing the original geometry?


We will release a new plugin version next month including new components that will allow users to define many export options for several file formats. In particular, most options for the dxf and dwg formats will be exposed, which should fix your issue.

We will update this topic when the plugin is updated.


**Thanks @mathieu1 **

Hello @mathieu1
Do you have any news about the release of the export module ?

Many thanks

1 Like

We are experiencing some minor delays but we expect to release the plugin in May. Here is a teaser just to prove my good faith :wink:

Apologies for taking so long, this feature has been part of a bigger change in the plugin that involved many moving parts!


:eyes: looking forward to it

Was just going to post a new topic, but found this topic.

We are exporting curves as DXF for a laser cutter and the default scheme of DXF splits all nurbs curves into parts, rendering the files totally useless for laser cutting. You need the “2007 Natural” or “R12 Natural” scheme, so they remain proper closed curves.

@mathieu1 I know your estimations for when things are released should always be taken with a grain of salt, but is the update ready yet? We are now in almost August and you said it would be ready in May.

We cannot start using Shapediver to create production files until we can specify the scheme for DXF files. I am also 100% sure that it used to work just fine with the DXF export, but I think we were using polylines back then, which are not good for laser cutting.

Do you have a new ETA for the update?

Ah yes, and another bug with the Shapediver DXF export: everything is scaled up by 200%, which is again something that simply cannot happen if you want to create files for production! If I export and re-import as DXF from Rhino it is fine. If I export using Shapediver and re-import, the files is exactly twice as large :see_no_evil:

@seltzdesign there are lots of users using the DXF export feature successfully, this must be an issue related to your model. Please post a minimal example that reproduces this problem. Many thanks in advance!

Strange, when I tried it today it is not scaled by 2x any longer. The lines are still broken into small pieces though as we cannot specify the export scheme, which should be set to “2007 Natural” or “R12 Natural” so that curves are not split into individual parts, but stay as one closed nurbs curve as they are in Grasshopper.

I am pretty sure this used to be fine, but now seems like a different export scheme is used that breaks the curves into parts and makes it unusable for a laser cutter.

When can we expect the new dxf export component where you can specify the scheme?

ps: I tried uploading a minimal example with the geometry and curves internalised and hooked up to the export components. For some reason though if I press one of the export buttons in Shapediver nothing happens !? ShapeDiver - Online Parametric 3D Configurator → any idea why this is not working?

Could you post the Grasshopper file here? The screenshot looks OK but I’d like to see the definition.

210710_Process C_Physical Fabrication of Products_internalized.gh (700.0 KB)

this is the part with everything internalised.

Since you didn’t answer the part about choosing the export scheme, I assume that its not possible to change it currently!?

Hello @mathieu1
Do you have any news about the release of the export module ?

Many thanks

1 Like

The export scheme cannot be changed currently, but it will be possible in the new version of the plugin. Unfortunately, we can still not commit to a release date, although the feature is almost ready. I will make sure to answer back here when the new version is ready to test.

Hello Mathieu,

I have experienced that the DWG/DXF export is different for a week. The DWG/DXF files are much bigger than they used to be (many more lines of code) and the shapes exported are, most of the time, no longer closed. Is ShapeDiver experimenting or changing the export scheme?

The direct consequence of that at the moment is that:

  • Some of our exported designs have bad geometries (see image in copy)
  • We need to manually close the shapes or our Laser/CNC cutting service will charge us extra
  • Some files are too big to be open. These files used to run perfectly.

Any information on how to fix this on our side would be valuable.


Hi @thierrygiles, an update which in some way also relates to the export functionality was rolled out several weeks ago. Although unlikely it is possible that this explains the difference. We would like to track it down, could you provide a minimal example?

Some background info: The export component you are using makes use of Rhino’s builtin DWG/DXF exporter using the 2004 Solids export profile on Rhino 6. I figured out that there is a bug for our Rhino 7 systems, because the 2004 Solids export profile apparently is not shipped anymore with Rhino 7. Therefore we will switch to the 2007 Solids export profile for Rhino 7. This bug should not be the cause for what you are experiencing, because your account is using the Rhino 6 system currently.

Please note that the coming new version of our plugin will allow to control each and every export option for DWG/DXF exports. In case you are interested to test this, please let us know, and we will invite you to the private beta.

Hello Alexander,

Thank you for the fast answer.

After more investigation, the problem happens with other user’s accounts and other designs. The issue is with spline curves.

Yes, definitely testing the new export option via a Beta account would be great and hopefully it will solve our export issue for the moment. Let me know which information you need from us.

All the best,

Hi @thierrygiles you will receive an invitation for the closed beta of our new plugin.
In order to track down whether there is a problem in the export component of the current plugin, please let me know the following:

  • Can you provide a minimal example that reproduces the problem?
  • Are you sure that the behavior of the export component actually changed? Could it be that you simply never came across this problem so far?

Hello Alexander,

We compared 2 exportation of the same file and they are different. We used some of the files for production today and the line were smooth and closed. The new one are not. We thought it was our new GH but even our older ones create the same error.

Here is an example file we made for rapid testing.

Looking forward to the invitation to the closed beta of your new plugin.

All the best,

Thank you @mathieu1 for letting us know.