_ToggleRightSidebar _ToggleLeftSidebar and their shortcuts don´t work

Recently I got accustomed to the Commands: _ToggleRightSidebar
and _ToggleLeftSidebar, but they don´t work anymore on Rhino Mac 5A766w (OS X 10.10.2).

The toolbar buttons on top of the window work as expected.

Just the commands and shortcuts don´t work.

Thanks… I see that too.
Filed as http://mcneel.myjetbrains.com/youtrack/issue/MR-1778

version 5A772w (on OS X 10.10.2) doesn´t solve the problem.

Yep, fix was too late to make it into this week’s WIP. --Mitch

Right… fix went in last night and I need to test it in a daily build now, if it’s working, it’ll go in the next WIP.

Commands: _ToggleRightSidebar and _ToggleLeftSidebar are still broken when Hide Toolbar is enabled. Using 5C83w, though been broken for a while, just getting around to reporting. Seen on three separate Macs.

Very annoying on a laptop when optimizing screen real estate! Thanks.

fwiw, these commands work for me… even when the toolbar is hidden.

(not very helpful i suppose… but just saying, they do work at least on my computers)

Hmm…you got me thinking by sayin’

If I:

  1. Start up Rhino in Hide ToolBar mode (my default), it does not work for me.
  2. If I uncheck Hide Toolbar it works
  3. If I recheck Hide Toolbar it works
  4. If I exit and restart Rhino in Hide ToolBar mode it does not work until repeat step 2

You at least got me to a work around, Jeff, so very helpful. Thanks!

This still sounds like a bug???

This is a bug that shows up when using command options in the sidebar, but not when using the command options dialog. This will be fixed in the next WIP release.

Thanks @marlin

I evoke both via the awsome ‘screen edges’ feature, as well as just typing the command, if that is the same as: [quote=“marlin, post:9, topic:18655”]
using command options in the sidebar

I see the bug with both under the conditions outlined above.

Same issue in 5c131w when staring up Rhino in Hide Toolbar mode.

Have to uncheck “Hide Toolbar” for _Toggle… to start working. Thereafter it works, even when Hide Toolbar is checked, for that session only.

This only exists when exiting Rhino, and hence starting Rhino, with Hide Toolbar checked.