Zoom and orbit issues

Zoom is fine with the trackpad but with the magic mouse it is near impossible, it jumps in or out way to fast.

Also orbiting every now and then decides it wants to rotate/orbit the object on an axis far out from where it should be so the object moves off the view when trying to orbit

I am not sure how Rhino selects the orbiting centre, but I found a little trick: when you want to orbit around an object, select that object and ZoomSelect. Deselect and zoom out again and your object will remain the orbiting centre.

Max.

is ZoomSelect a command? i can’t see/find it

Zoom is a command. Selected is an option in the command.

there’s a built in macro for Zoom Selected. select an object then type ZS (return or space bar)

gotcha, solves the orbitting but is a bot of a ‘work around’ doesn’t solve the zoom stuttering

Does the behavior continue in Shaded or Wireframe display mode or does it improve?

I’ve experienced similar issues when viewing in other modes (especially Ghosted or Rendered). Seems the graphics card just can’t keep up. I should boot into WinRhino in Bootcamp (on the same machine) to see if the behavior is similar, but I sort of recall it being a bit better for some reason on Windows side.

As for Zoom Selected, I use this only about 6 million times a day. Would actually prefer if this were default behavior (especially helpful for orbiting), but creating a custom shortcut (Control + Z) seems to be a bit quicker than typing ZS. ~Dave

put it on a mouse button (or trackpad gesture) :wink:

hi everyone. İ’m having touble zoom in and out with my Mouse scroll. İ search the forum and i found that chnge ing scale factor in options/view from 1.0 to 0.9 will solve the problem. but i couldn’t change it to 0.9 i can only change the numbers 1,2,3,4…9 could you help me. thanks

Zoom + option “Target” may be useful for setting an orbit centre. From Rhino Help:
A rectangular window forms to define the zoom with the target as the view center.
When you rotate a view after Zoom Target, the scene will rotate about the target. This is particularly useful in perspective views.
I have created an alias “ZT” for it: '_Zoom _Target

Max.

You also posted this in the Rhino for Windows category. Which version are you running?

I had the same problem, had to turn off the ‘scroll with inertia’ in preferences - accessibility - mouse & trackpad - mouse options to get any useable function out of the zoom. You can adjust the zoom speed in there too. Not sure about the orbiting problem tho.

I also use rhino with magic prefs to get my middle button pop up function with my Magic Mouse too.