Zebra showing as plain white surface


#1

issue cropped up with zebra again, just showing as white ?

using commercial release, 5.3.2


#2

I’m also having the same issue when using EMap, select your object, zoom and bingo, all goes white ?? @dan @BrianJ , any ideas or a bug ?


#3

does it work when you change the surface normal?


#4

@RichardZ seems to make no difference, somethings not right for sure :neutral_face:


#5

i had such an issue, somehow the color of the stripes matched the background color, changing colors revealed it again, you can try if that somehow hooked up. or its far too dense.

you can also try ExportPreferences to the desktop for example, then use ResetPreferences and see if zebra works again then reimport the seetings with ImportPreferences and see if it stops working again or if it even fixed it.

lately i also have been having issues with sudden awkward behaviours… some things can get fixed through export reset import but not all, still one issue remains which forces me to rebuild all settings from scratch…


(Brian James) #6

I’m not able to reproduce this in 5.3.2 so far. Can you post a 3dm where this happens for you? Also, please paste the text from Rhinoceros menu>About Rhinoceros>More Info in a reply here.


#7

Brian, trying going to preferences, general, never repeat command, and add ZebraOff, EMapOff , then run the commands Zebra and Emap


#8

2 simple objects in this file, play around with Zebra and Emap on one or both and I’m seeing different results, it seems to be intermittent and restarting rhino works, for a while, then seems to return cushions.3dm (3.8 MB)

Software information

Software versions
Rhinoceros version: 5.3.2 (5D197)
IronPython version: 5.1.2015.131
Language: en-GB (MacOS default)
macOS version: Version 10.12.5 (Build 16F73)

Plug-ins
None

Third party kernel extensions
com.razer.common.razerhid (19.41) 5685569B-C4C1-3043-AF41-4B7D7559B3EB
com.nvidia.CUDA (1.1.0) DD792765-CA28-395A-8593-D6837F05C4FF

Hardware information

Computer hardware
Hardware model: MacBookPro11,3
Processor: Intel Core i7-4870HQ CPU @ 2.50GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 750M 2048 MB
Memory: 2048 MB
Screen size: 1440 x 900
Displays: Color LCD (221dpi 2x)

USB devices
Apple: Card Reader
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.17.5 355.10.05.45f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 2x
Mip map filtering: None
Anisotropic filtering: None


(Brian James) #9

Thanks, I tried that but Zebra still works here.

I’ll see if I can figure out what causes it to happen, thanks for the file and machine info.


(John Brock) #10

I’m running 5.3.2 on an old MBP wtih an nVidia GeForce adapter, and Zebra is OK here:


#11

@BrianJ This is the kind of thing I’m getting, seems to white out as soon as I zoom or move the cursor, and one object stays with its zebra mapping ?


(Brian James) #12

Thanks for the further info. I am still unable to reproduce this and in comparing my system info the only differences with your machine are in regards to the Third Party Kernel Extensions. Here’s what I have…

Third party kernel extensions
com.3dconnexion.driver (10.2.2) 598AA167-B9DE-3DFC-8288-33EEA0E4951B
foo.tun (1.0) FBA9A61D-E7BB-391C-92E2-C1D85BB065B2
foo.tap (1.0) FF769517-6401-3F61-9190-B967BF20C0B2

@dan @marlin Any ideas if this may be involved in the reported issue?

Other then that, I’d wonder if maybe you’re using multiple monitors?


(John Brock) #13

@milezee
Have you checked to see if you have the same issue in the Mac Rhino WIP?
https://wiki.mcneel.com/rhino/mac/wip


#14

@BrianJ hi Brain, no I’m just using my MacBook Pro, no extra monitor

@John_Brock I’m seeing the same behaviour on the WIP too :confused:


#15

Hi
In the Rhino preference panel> Display Mode, is “Use advanced GPU-based illumination” active? (In the mode you use for Zebra)

Simon


#16

hi Simon, thanks for the suggestion, seems to make no difference whether on or off :confused:


#17

:unamused: Sorry.
An additional check might be creating a guest account, installing Rhino and DO NOT install or launch any hardware or software (including the razer mouse).


#18

ah, do you know , the razor mouse is new to my set up, I wonder if this has had an effect ??


#19

I find it improbable, but as I’ve seen that you have the razer software installed, a guest account test without any installed hardware or software installed, it clarifies where the problem is. If others (including me) do not have this problem, it means there’s a local problem on your Mac. Good luck. I go to bed, it’s late in Italy.


#20

maybe this is related?