Rhino 4. Zebra, Environment, Shade all screwy for this surface. Is R5 better?

Here’s a surface. When I try to looks at is with Zebra, Environment, Shade, I get a lot of garbage.

I have to believe this is a bug. What’s going on?

Is this fixed in Rhino 5?

Sorry … i thought there wa a place to submit the 3dm file. Not much use without it …

You can submit the 3dm file right here. Either drag and drop into your message or use the Upload button (the one with the Up Arrow).

Most zebra stripe problem are caused by the display mesh being too coarse, which can be fixed by refining the mesh. Clickon Adjust Mesh in the Zebra Options panel. The simplest fix is usually to move the slider all the to the right to “More polygons” in “Simple controls”. If that doesn’t work then further refinement will be needed with “Detailed Controls”.


Here’s the file

example.3dm (505.9 KB)

Tried mesh already. No help. Similar problem with Shade, Environment, etc.

Just a quick comment. The object in this file is a bad object - it gets selected when you run the SelBadObjects command. I am on my way out but just tried to untrim this and that doesn’t seem to work - the feedback is: Selected edge belongs to an inner loop but face has one loop. Nothing done.
How did you make this?

Agree, the surface is a bad object. Anything other than wireframe mode (including shaded) appears to be ignoring that the surface is trimmed.

@davidgolber Can you upload the untrimmed surface and the trimming curve?

Fixed surface. Removed a portion of the trimmed edge and retrimmed. I don’t know the origins of the problem.

Steps to fix:

  • Make a copy of the surface
  • DupEdge (selected all edge segments)
  • RemoveEdge (I tried different sections of the edge to find which one fixed the problem)
  • Trim with the curve from DupEdgeexample_DC1.3dm (1.5 MB)

Thanks for the help, guys. I didn’t try fixing the surface I sent you. I just went back and regenerated it, but cleanly. The clean surface has no problems.

The one I posted was the result of: do this, try this, trim this, try this, etc. I couldn’t tell you the sequence of what I did if I tried. But having pushed it around a lot, I finally just did it cleanly, and it worked.

But knowing what the problem was in general was the thing that led to the solution.

Thanks again

You might consider running the CheckNewObjects command so as soon as a bad object is created, you are notified and can deal with it right then.
I’ve found it saves me unexpected frustration.