ZBrush Mesh Import Problem


#1

I am having a problem importing a mesh from ZBrush.

I export from Rhino as a obj, decimate in ZBrush, and bring it back into Rhino as an STL. That is it. Should be (roughly) the same size, right?

I have also tried export as an STL from Rhino, but with no change.

It’s really weird. I put a bounding box and the mesh and it measures 3.50mm in length. I open the mesh in NetFabb and it says it is 120.39mm. I use the ZPlugin to update the size ratios, and the resulting mesh now says it is 21.85mm in NetFabb. Still, Rhino brings it in at 3.5mm.

Temp.7z (105.8 KB)


(Dale Fugier) #2

Generally, STL files are unitless. So you might have to scale the geometry after importing.


#3

Please look at the mesh, I do not believe it to be a scaling issue. It’s also not centered. I use the same workflow on other meshes without a problem.

One more thing, on this mesh, I get an error when importing to Rhino:

The last time this happened, I didn’t get an error. Unfortunately I did not save that mesh. I have a RhinoGold by TDM tool called Pave, but I’m not sure what that has to do with anything. I thought this was for sure a ZBrush issue until I opened the file in NetFabb.


#4

I’ve had good result exporting from ZBrush as OBJ. Going back and forth between Rhino and ZBrush and everything pops into place as it should.


(Dale Fugier) #5

Have you reported this to TDM?


#6

@SamPage, as I was working through this problem, I also tested exporting as an OBJ file. It always came into Rhino at the correct scale, no matter if the size ratios in ZBrush were updated or not. The TDM error was present for both the obj and stl file import.

Mesh files are unitless. Enclosing the mesh in a unitless bounding box gives me the measurements of 21.9X23.2X10.6. In my Rhino file, my units are set to mm. When the mesh comes in, it should be 21.9mmX23.2mmX10.6mm. Having it come in at 3.500mmX3.712mmX1.718mm is pretty weird.

I’ll just use an OBJ file from now on.


#7

OBJ is the file format I use too.


#8

Hi,

When you export STLs from Zbrush you have to update size ratios. If you are exporting in mms the mm button needs to be highlighted. If you update the size ratios as mms but highlight the inch button you will get the results that you are seeing.


#9

Also, if you have move to origin highlighted in advanced options it will change the location of the file on the screen.

Happy Zbrushing