Rhino Export STL ASCII / Binary at 0kb


Hi Rhino Forum,

I’ve tried to export a closed surface / mesh to STL but the file size remains at 0kb. These are about .5" by .5" by 5" tall column and should have a small file size (actual file size is about 188kb). However, putting this into my 3d printer or other repair softwares results in an error message.
Unfortunately the only type of input my 3d printer takes is an STL, so I’m assessing how best to export to be readable by other software other than itself.

If the export is 0 Kb, nothing is getting exported. Is the object being exported valid? Do a SelBadObjects to see. Rhino will not export invalid (bad) objects.

If it’s valid and not exporting, please post the Rhino file with the object here along with your STL export settings.

Stick.stl (5.0 MB)

Here’s the file in question. It’s not just this one file. Essentially all my Rhino 5 programs have all been exporting with 0kb. thanks for looking into this.

That’s an STL (not Rhino) file and it seems to look OK here.

How many Rhinos do you have? Is this all file type exports (dxf, obj, etc.) or just STL?

I have three machines running Rhino 5 that I tested on. Two personal, one corporate. It seems all file types that do mesh export: obj, vrml, etc. are creating problems as well.

Well, we’re going to need more info to go on…

You have the latest service release of V5?
What version of Windows? Updated recently?
Are these problems recent? Did they start with an update of some kind?
Does this happen with absolutely all files, even a simple box?
Do you have a Rhino file you can post here that doesn’t work on your end?

stick.3dm (269.9 KB)

I have the latest build of windows with updates just a few days ago
I have the latest up to date Rhino service release as well.
These problems are recent, with latest update to Windows 10. It’s happening even with a simple box as well, registering 0kb.

Thanks again for taking a look.

Works here in R6 SR6 / R5 SR14

Hmm, very odd that it should be happening on 3 different machines. The STL export seems to work OK here in V5 or V6 (I’m on Windows 8.1 though). I don’t have any explanations for the moment. What are your STL export settings? If you use _Mesh to mesh the object first, then export the mesh object, does it work any better?


You Have to have the object selected in order for it export.

I have the same problem. v6 sr24.

Hello - does this (0 kb) happen with any file? Are you exporting meshes directly, or Nurbs objects to be converted to meshes during export?


I tried making only a cube. It also happens with that. So it happens with the 2 files I tried. I am starting with Nurbs objects.

Hi Mitch - can you Mesh the polysurface cube first, and export the mesh directly - any different?


It makes no difference if I try to export the mesh.

And, just to make sure - Ascii export works, or also 0?


What is Ascii export and 0?

Sorry - when you export, you can send the file out as binary or ascii - just checking that both behave the same way and deliver a 0 kb file.



I see that zero!


Yes both say 0 Kb