Obj mesh from zbrush looks jagged


#1

The obj made from zbrush looks jagged when imported to rhino
The mesh looks very smooth in the zbrush view port but when it is imported to rhino the mesh is totally different. It looks like stacked box.


viewport from zbrush

viewport from Rhino (triangular-mesh exported from zbrush)

viewport from Rhino (quad-mesh exported from zbrush)

This is just a part of the big model just to test the setting and I have tried for different part of big model and in some cases it looks more horrible than this.

obj.zip (855.8 KB)

Sorry for posting such question her as I know that this problem must be highly related to zbrush but I’m new to zbrush and it is taking too much time to figure out how to solve it, as I have tight schedule to finish this project…
Maybe i should ask in zbrush forum but i do not know where it is good to ask either:sob:

Anyway, the workflow I have been doing is
A0. make rectangular pipes from several lines
-----(the model space in in “m” as I was also using Karamba and could be the part of the problem…)
A1. exporting rectangular pipes from Rhinoceros as obj
A2. import to zbrush
A3. do Dynamesh
A4. do subDiv
A5. export it with “no group” as Triangular-mesh or Quad-mesh as obj
A6. import it to rhinoceros

I’m assuming that the doing something in zbrush before exporting could solve the problem but couldn’t find appropriate solution.

Baking displacement seems to be the solution but the button is not activated in my case.
Also this solution seems to use this maps for rendering and does not actually change the mesh.
I am using this model to both render and 3d print so if it doesn’t change the jagged problem, it would not help.

I even tried doing other options such as…
B1. dynamesh -> subdiv -> dynamesh
B2. dynamesh -> subdiv -> dynamesh -> subdiv
B3. dynamesh -> Claypolish

B1,B3 seems to be less jagged but it is still different from what it looks like in zbrush and this process useless as the detail is lost in both program.
B2 is still jagged when imported to rhino.

As what I want to achieve is turning lines to have certain thickness and transition smoothly, alternative solution not using zbrush can also be helpful.

I used grasshopper plug-in cocoon before but the cocoon-refine doesn’t work in any option I tried for several days.

This articles mentioned Meshmachine can replace the cocoon-refine, but the example file links are broken and couldn’t figure out how to use it myself.

Any advice would be very helpful.


(Laurent Delrieu) #2

I just think it is the now “classical” far from the origin problem. Put your mesh on 0.
Mesh still are in float in Rhino, no double.


#3

That perfectly solved! you are miracle!


(Laurent Delrieu) #4

No problem, you can smooth also the mesh if needed. For that I use Laplacian smoothing from weavebird.
https://rhino.github.io/components/weaverbird/laplacianSmoothing.html