Write unit type in a draft dimension?

How can I get the draft dimension in my Rhino document write out its unit?

Right now, it says 1.82… but what is it? Meters or millimeters?

Even if I change the document unit type, it stays the same.

Add your preferred unit decoration in the Named annotation style you’re using:

No, that’s exactly it, I don’t have a preferred one. I’d like Rhino to tell me what it actually is, because that’s what I’m uncertain of.

The “scaling” question when you change units is really weird to me, since in the CAD world (coming from Solidworks/Alias) there is never any scaling, everything is always 1:1.

Further, I was confused by me changing from meters to millimeters, and then having a number distance in Grasshopper still appearing to be meters…

Every Rhino file has a current Unit system.
This is established when you start the new file and choose a template file.
Like SolidWorks, we always assume we are modeling at 1:1 at full scale.
The current unit system is displayed in the Status Bar at the bottom of the application window between the coordinates and current layer:

You can change the file unit system in Options > Units
If you change the unit system, Rhino will ask you about scaling. If you are modeling in Inches and you thought you were in MIllimeters, when you are asked about scaling, say No. You still want “10” to be 10.
If you knew you were modeling in inches and want to switch to millimeters, then you would say Yes to scaling so your inches are multiplied by 25.4 to be millimeters.

The dimensioning tools in Rhino also support a Alternate units. Int his case you would normally use the prefix/suffix to clearly identify the unit.

Thank you for the information, but I’m afraid I still don’t understand one thing:

This is my document with units set to meters.

This is the same document with units set to millimeters. I’ve even recreated the dimension. Why on earth doesn’t it read 1820 here?

Same with this distance thing in Grasshopper, which is why I wanted to switch to millimeters in the first place. 0.022 is not very readable, when it should say 22.

How did you answer the question about scaling?

As for Grasshopper, sliders are defined by you and are not automatically changed when you change document units in Rhino.

I, naturally, answered no to scaling. I don’t want to scale my object. It’s 1:1. It’s CAD. I shouldn’t have to think about this.

If I answer “yes”, the entire document goes crazy, with the draft units and arrows not showing up at all, and the model becoming huge (just look at the grid):


I have to answer no, but I don’t understand why the draft unit doesn’t change from 1.82m to 1820mm.

Please read this reply by John once more:

If you say No to scaling, 1.82 units will still be 1.82 units.

Please look at my picture one more time. The entire document goes crazy then I say Yes.

And again, this is the CAD world. Why would I have to scale my model like I’m importing something in 3D Studio Max (which obviously doesn’t have any clue about the real world). I know the size of my model. It is modelled in the correct scale. It’s the Rhino unit display that is wrong.

I’m honestly truly baffled by this.

I really can’t tell from that picture. Please post the 3dm file - preferably both in the state before you change units and after.

Well, yes, of course. Now one side will be 1820 units instead of 1.82 units. So, annotation text that was defined to be, e.g. 2 units are still 2 units and therefore no longer visible. The grid that was defined to be 100 units - and looked huge compared to 1.82 units - still is 100 units but now tiny compared to 1820 units.

Ok, I think I finally get it now. Rhino is like 3D Studio Max, and not like all other CAD software on the market. Rhino assumes its world view is correct, and that all objects entering it have no clue, while other software assumes that all objects know their size, and adjusts its world view to conform.

I hope you can see that from the perspective of where I’m coming from, this is really backwards.

The thing that made it click was that after scaling my model (which still feels utterly wrong), Grasshopper’s undefined units jumped up to the scale I wanted them to be.

I managed to fix the grid, but I still can’t fix the dimensions. This is the only option I have, and what you are looking at is not a rectangle, but a line with a dimension on it:

dimensions.3dm (30.7 KB)

If you can tell me how to fix this, I’d appreciate it.

In your picture, expand the Annotation Styles and change the settings there:

Note that the recommended workflow in Rhino is that you annotate your model in a Layout. The font height as in that picture (3.5 units - here mm) is good for printing on paper. If you use this annotation style in the model space as well, you would want to scale this up by changing the Model space scale value.

If you are only annotating in the model space, you could just have this model space scale set to 1 and change the font height (and arrows, gaps, etc) to your liking.

It might be easier for you to start a new document from a mm template, and import and scale your File into this one. Dimensions should be better then.
I’m generally using my own templates with different dimension styles depending on detail view scale, own tolerances, lines, hatches and Layouts from A4 to A0

1 Like