Wireframe displays random pointy objects that aren't there

Something really weird happens to my wireframe displays. I am not 100% sure how to reproduce it because it doesn’t go the same way every time and doesn’t go away again (even after reverting the file to last opened, restarting Rhino or my MacBook).

The best I can do to describe is
Open the file > enable the clipping plane in top view (already weird things happen with curves in top view) > set the display mode to “Pen_IV” in top view -> all other (wireframe views go wild).

It happened for the first time after the latest update. I am assuming it has something to do with the clipping plane and the custom pen display mode I was using when it came up.

Sorry for the bad description but I really have no idea what I’ve done to cause this. Has anyone ever even seen anything like it?

It makes Rhino unusable so I would prefer to go back to the latest working version in the meantime. Could you please provide a download link?

Rhino Version 6 (6.20.19323.01022, 2019-11-19)
MacOS Catalina 10.15.1 (19B88)
MacBook Pro (Retina, 15’, Mitte 2015)
GPU Intel Iris Pro 1536 MB

Pen_IV.ini (5.8 KB)
Preferences_20191120.plist (428.4 KB)
PVZH-PW1-Ergonomie-20191121.3dm (5.4 MB)

Hi - I can see something similar with your file on my system but I’m not completely sure if this is the same issue. 1) I don’t need to use any special display mode - just using factory-default wireframe also shows this; 2) going back to 6.18, I can still see this happening.

Which version were you running before updating to 6.20?

Note: apparently several other users have reported something similar - this is logged as RH-54879 but this report is not open to the public.
-wim

Hey wim, thanks for your reply and sorry for not reporting back. I am not sure about the version I was using before, maybe it has to do with the way the file is set up after all. It’s just I never experienced this type of display error until the last update – anyway, good to hear that it is being worked on. Meanwhile I’ve worked around the issue by not using the clipping plane. Thanks anyways

Hi - apparently it’s hard to find computers that we can reproduce this issue on. Could you run SystemInfo and attach the result here? Perhaps we have a machine somewhere on the US West Coast that resembles yours.
-wim

Hi, I’ve been working around the issue for some time now but it’s happening again and I am curious to know if there has been any progress on this issue.

This time I am also experiencing random lines in Layouts: grafik
They even end up in the print … No clipping plane in this file so I’m guessing that is not the problem.

If it’s still of interest here is my SystemInfo

Rhino 6 SR21 2019-12-15 (Public Build, 6.21.19349.01012, Git hash:master @ a9aff0b2a2e07411210fef500868737069a15926)
License type: Commercial, build 2019-12-15
License details: Cloud Zoo.  In use by:  ()

Apple Intel 64-bit macOS Version 10.15.3 (Build 19D76) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro11,4
Machine name: MacBook Pro
Language: en

Intel Iris Pro OpenGL Engine (OpenGL ver:4.1 INTEL-14.4.23)

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: Height
  
  Vendor Name: Intel Inc.
  Render version: 4.1
  Shading Language: 4.10
  Maximum Texture size: 16384 x 16384
  Z-Buffer depth: n/a
  Maximum Viewport size: 16384 x 16384
  Total Video Memory: 1536 MB
  Graphics: Intel Iris Pro
  Displays: Color LCD (221dpi 2x)

Graphics processors
  Intel Iris Pro (1536 MB)
    Color LCD (1440 x 900)

USB devices
  Apple Inc.: Apple Internal Keyboard / Trackpad
  Broadcom Corp.: Bluetooth USB Host Controller
  Logitech: USB Receiver

Bluetooth devices
  None

Third party kernel extensions
  net.pluckeye.kext.pluckeye (1) 2D70D328-3B48-3FE7-8F59-C24FD85BD2D7
  org.pqrs.driver.Karabiner.VirtualHIDDevice.v061000 (6.10.0) 4D004D1A-ED2F-3780-AD53-A10F286EC759

Third party plugins
  None

Rhino plugins
  /Applications/Rhinoceros 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp	"RhinoCycles"	6.21.19349.1012
  /Applications/Rhinoceros 2.app/Contents/PlugIns/import_PDF.rhp	"PDFReader"	6.21.19349.1002
  /Applications/Rhinoceros 2.app/Contents/PlugIns/NamedSnapshots.rhp	"Snapshots"	6.21.19349.1002
  /Applications/Rhinoceros 2.app/Contents/PlugIns/RhinoBonusTools.rhp	"Rhino Bonus Tools"	6.21.19349.1002
  /Applications/Rhinoceros 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp	"Grasshopper"	6.21.19349.1012
  /Applications/Rhinoceros 2.app/Contents/PlugIns/PanelingTools.rhp	"PanelingTools"	6.21.19349.1002
  /Applications/Rhinoceros 2.app/Contents/PlugIns/AnimationTools.rhp	"AnimationTools"	6.21.19349.1002
  /Applications/Rhinoceros 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp	"Commands"	6.21.19349.1012
  /Applications/Rhinoceros 2.app/Contents/PlugIns/SolidTools.rhp	"SolidTools"	6.21.19349.1002
  /Applications/Rhinoceros 2.app/Contents/Frameworks/RhMaterialEditor.framework	"Renderer Development Kit"	6.21.19349.1002
  /Applications/Rhinoceros 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp	"RDK_EtoUI"	6.21.19349.1012
  /Applications/Rhinoceros 2.app/Contents/PlugIns/Displacement.rhp	"Displacement"	6.21.19349.1002
  /Applications/Rhinoceros 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/BlockEdit.rhp	"BlockEdit"	6.21.19349.1012
  /Applications/Rhinoceros 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp	"IronPython"	6.21.19349.1012
  /Applications/Rhinoceros 2.app/Contents/PlugIns/RhinoRender.rhp	"Rhino Render"	6.21.19349.1002

Hi - that doesn’t look good.
The bug with the clipping plane on certain Macs running an Intel Iris Pro (RH-54879) was solved about a month ago. But that was very ClippingPlane-specific so this sounds like it’s something else.

OK - I see that you are running 6.21 and the fix was in 6.23.
Please change your update settings to Release Candidates and download the latest version.
Let us know if that fixes things.
-wim

Thanks Wim, that seems to have resolved the issue!

Thanks for letting us know!
-wim