Rhino 6 for Mac Display Errors (Clipping Plane and Top View)

Problem only seems to happen when clipping planes are enabled or when looking at the model from top view.

System Info:
Rhino 6 SR19 2019-10-25 (Public Build, 6.19.19298.01152, Git hash:master @ 01a413724f36af3118af8e0ad5305b6671ef66be)
License type: Educational, build 2019-10-25
License details: Cloud Zoo. In use by: Noah Shipley ()

Apple Intel 64-bit macOS Version 10.13.6 (Build 17G6030) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro11,1
Machine name: MacBook Pro
Language: en-US (MacOS default)

Intel Iris OpenGL Engine (OpenGL ver:4.1 INTEL-10.36.23)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1536 MB
Graphics: Intel Iris
Displays: Color LCD (227dpi 2x)

Graphics processors
Intel Iris (1536 MB)
Color LCD (1280 x 800)

USB devices
Apple: Internal Memory Card Reader
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
None

Third party kernel extensions
org.virtualbox.kext.VBoxDrv (5.2.18) 4B812769-A078-3E16-B9D1-DCAB645482E4
org.virtualbox.kext.VBoxUSB (5.2.18) 38AC00F1-4F4C-3101-B8E0-4F07161A728E
org.virtualbox.kext.VBoxNetFlt (5.2.18) 80DA38DE-39E0-3DE7-A207-73D55CF17079
org.virtualbox.kext.VBoxNetAdp (5.2.18) CC938DAD-56D8-3616-B7B0-709D040CE41B

Third party plugins
/Library/Frameworks/iTunesLibrary.framework/iTunesLibrary

Rhino plugins
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.19.19298.1152
/Applications/Rhinoceros.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.19.19298.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.19.19298.1152
/Applications/Rhinoceros.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.19.19298.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.19.19298.1152
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.19.19298.1152
/Applications/Rhinoceros.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.19.19298.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 6.19.19298.1152
/Applications/Rhinoceros.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.19.19298.1002
/Applications/Rhinoceros.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 6.19.19298.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.19.19298.1002

Hello - does this happen with any file?Say a new file with just a box? If not, can you please post or send to tech@mcneel.com a file that shows the problem, along with a link back to this topic?

-Pascal

I think I found an existing bug report for this.
Unfortunately, it is not open for public view:
https://mcneel.myjetbrains.com/youtrack/issue/RH-54879

It’s on the list and the developer knows about it.

Hi, thanks for getting back to me! It doesn’t happen with a simple box, but seems to happen with more complex shapes. I’ve attached a file (a solid extrusion of a closed curve with the clipping plane enabled) that displays a similar error. EDIT: The error only seems to happen when curves are present—if I hide the curves, everything works as expected. ClippingPlaneError.3dm (3.4 MB)
Here is an image of what the error looks like in wireframe view:

We believe this issue may be fixed in the latest Release Candidate for 6.21. Please give it a try and let us know.

Hi Recently upgraded to R6 & Catalina have just attempted to create a clipping plane after a day or so modelling.

Im getting a lot of crazy geometry when the clipping plane is active In all view ports it doesn’t happen on a simple file like a single box a previously discussed. I Wondered if it was something to do with the blocks in the file but i have removed them all and makes no difference, and it’s telling me there’s no bad objects.

Rhino 6 SR21 2019-12-15 (Public Build, 6.21.19349.01012, Git hash:master @ a9aff0b2a2e07411210fef500868737069a15926)
License type: Commercial, build 2019-12-15
License details: Cloud Zoo. In use by: Quinn ()

Apple Intel 64-bit macOS Version 10.15.2 (Build 19C57) (Physical RAM: 64Gb)
Mac Model Identifier: MacPro6,1
Machine name: Quinn’s Mac Pro (2)
Language: en-GB (MacOS default)

AMD Radeon HD - FirePro D700 OpenGL Engine (OpenGL ver:4.1 ATI-3.4.19)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 6 GB
Graphics: AMD FirePro D700
Displays: LED Cinema Display (109dpi 1x),  (268dpi 2x)

Graphics processors
AMD FirePro D700 (6 GB)
AMD FirePro D700 (6 GB)
LED Cinema Display (2560 x 1440)

USB devices
Apple Inc.: Bluetooth USB Host Controller
Seagate: BUP Slim BK
Apple Inc.: iPad
Apple Inc.: Apple Keyboard
3Dconnexion: SpaceNavigator
Apple Inc.: Apple LED Cinema Display
Apple Inc.: Display iSight
Apple Inc.: Display Audio

Bluetooth devices
STMicroelectronics:
Apple: Apple Magic Mouse

Third party kernel extensions
com.3dconnexion.driver (1.1.3) 7F3D461C-BC8E-3D27-A964-2FCC8BE205E2
com.kairos.driver.DuetDisplay (1) 7620686C-E9CE-3C70-AA12-DC77DABA52DD
com.avast.FileShield (4.0.0) 0B9FE58B-1AA3-3873-9E0F-BEC1842AB578
com.avast.PacketForwarder (2.1) 61DFB6DC-2B55-38A5-9C71-A775FD0DBDF5

Third party plugins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient
/usr/lib/log/liblog_network.dylib

Rhino plugins
/Applications/Rhinoceros.app/Contents/PlugIns/SolidTools.rhp “SolidTools” 6.21.19349.1002
/Applications/Rhinoceros.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.21.19349.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 6.21.19349.1012
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.21.19349.1012
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.21.19349.1012
/Applications/Rhinoceros.app/Contents/PlugIns/RhinoLabsTools.rhp “Rhino Labs Tools” 6.21.19349.1002
/Applications/Rhinoceros.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.21.19349.1002
/Applications/Rhinoceros.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.21.19349.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.21.19349.1012
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.21.19349.1012
/Applications/Rhinoceros.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.21.19349.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.21.19349.1002

I have uploaded a file to the large upload bit.

would be restful to know if there is a work around. thanks

Hi! Have you tried the 6.21 Release Candidate? If that doesn’t solve it, one workaround I found was to hide all curves, lines, and polylines.

Hi thanks for your feed back yes i’m on 6.21 and just tried hiding curves, lines,and polylines but unfortunately none of the above solve my issue.

I do hope they can resolve this quickly as my workflow needs to use clipping planes & make 2d but i haven’t had any success with that either.

Hi - YT item RH-54879 is still open and is sadly not something that is easily reproducible on all hardware. Because of that, there’s no easy fix.

Just to make sure that I completely understand this. You are NOT saying that this is something that started happening on your hardware when you installed Catalina, right? You rather upgraded to RH6 and Catalina at the same time or didn’t use clipping planes on RH6 before installing Catalina?

About Make2D - the output of that command isn’t affected by this display issue with clipping planes. I see that it takes a very long time to generate the 2D output on my performant PC but there doesn’t seem to be (much) wrong with the result. Are you seeing something else?
-wim

Hi Wim

Thanks for getting back to me. I unfortunately can’t clearly remember the order of events with regards to rhino 6 and Catalina installation I think I ran rhino 6 evaluation on mojave for a few weeks then I upgraded to Catalina then bought the Rhino 6 for Mac but didn’t use clipping planes on Mojave in the evaluation. Today I was using my other hardware and clipping plane / make 2d works a lot better but edges do disappear when the clipping plane is active so might have found a workaround. but would be great to get this sorted on my Mac Pro.

Rhino 6 SR21 2019-12-15 (Public Build, 6.21.19349.01012, Git hash:master @ a9aff0b2a2e07411210fef500868737069a15926)
License type: Commercial, build 2019-12-15
License details: Cloud Zoo. In use by: Quinn ()

Apple Intel 64-bit macOS Version 10.15.2 (Build 19C57) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro11,3
Machine name: Teri’s MacBook Pro
Language: en-GB (MacOS default)

NVIDIA GeForce GT 750M OpenGL Engine (OpenGL ver:4.1 NVIDIA-14.0.31 355.11.11.10.10.143)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB
Graphics: NVIDIA GeForce GT 750M
Displays: Color LCD (221dpi 2x)

Graphics processors
Intel Iris Pro (1536 MB)
NVIDIA GeForce GT 750M (2 GB)
Color LCD (1440 x 900)

USB devices
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller
3Dconnexion: SpaceNavigator
Apple, Inc: Apple Keyboard

Bluetooth devices
Broadcom:
Apple: Apple Magic Mouse

Third party kernel extensions
com.3dconnexion.driver (1.1.0) 94E8C49C-EDED-3526-88BE-E7207560C0D2
com.kairos.driver.DuetDisplay (1) 7620686C-E9CE-3C70-AA12-DC77DABA52DD

Third party plugins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient
/usr/lib/log/liblog_network.dylib

Rhino plugins
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.21.19349.1012
/Applications/Rhinoceros.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.21.19349.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.21.19349.1012
/Applications/Rhinoceros.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.21.19349.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.21.19349.1012
/Applications/Rhinoceros.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.21.19349.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.21.19349.1012
/Applications/Rhinoceros.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.21.19349.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 6.21.19349.1012
/Applications/Rhinoceros.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.21.19349.1002

1 Like

@wim Hello Just an up date I have gone back to using Rhino 5 for Mac as a workaround the file works as expected in Rhino 5 but Generates a lot of unwanted Geometry In Rhino 6 when using the clipping planes. I know you’ve said this in not an easy fix but Im wondering if you know if there is any progress with this issue as i would like to go back to using Rhino 6 asap.

Kind regards

Hi - I’m afraid there hasn’t been any progress on this particular issue.

Just to make sure that I fully understand this - I see that I didn’t get an explicit confirmation on this last time. The bug in Rhino 6 is a display issue only, i.e. no extra geometry actually gets created. And the output of, e.g., Make2D is also correct (and can be checked when the clipping plane is turned off). Is that also what you are seeing?
-wim

Hi Wim

Version 6 (6.22.20028.13212, 2020-01-28) just up dated to this and it seems to have resolved my issue.

Great work team.

That’s great to hear. Thanks for letting us know.

1 Like