Wirecut works with a cone segment of radius A, but not with radius B


#1

Hi,

I’m trying to wire cut a cone segment into two equal pieces along it’s axis. I manage to do it when the radius of the segment is as it is on the left piece, but not when the radius is slightly larger as on the right.

The halved section on the far left was trimmed from the cone, but the piece on the far right I had to construct by doing arc, extruding to the point etc… It just won’t cut it.


(Rajaa Issa) #2

Are you cutting with the vertical line segment? Can you please send the file?


#3

Yes, with the vertical line segment.

For some reason now it doesn’t work even with the smaller arc.

Here is the file.

Cone wirecut problem.3dm (193.0 KB)


(Rajaa Issa) #4

I tried to cut at my end as well and it worked. If you can repeat the case when it fails, please let me know. It can be some special case with some funny direction that creates invalid cut solid.


#5

Ok, thanks for quick reply.

What might be the problem then…?

I tried again with Rhino 32bit instead of 64, and it didn’t work. Wirecut works with any square form, but not with any cone, not even with truncated cone. Everything seems to be working until “Part to cut away”, when the whole cone stays selected. And when I continue from there, nothing happens.

Also, no boolean operations work with cones.

I have restated my computer.

My sofware version is:

Version 5 SR8 32-bit
(5.8.40315. 18095, 15.3.2014)
Developer Build

Computer details:

Dell Latitude E7240
Processor: Intel® Core™ i7-4600U CPU @ 2.10GHz 2.70GHz
RAM: 4GB
64 bit os (windows 7 pro Service pack 1)


#6

Hmm… maybe your “Developer build” is a bit broken…


(Pascal Golay) #7

got a crack in it??

-Pascal