WIP Window 7? Black World Space


I get these black inoperable flat World Space, upon loading the 6WIP on my Windows 7 Bootcamp. Safe Mode opens and I can use wireframe geometry. 5.0 runs fine.Also running the WIP well on my Bootcamp windows 10 laptop.

Any help would be appreciated. Not sure if its a setting of mine or the WIP. Thanks much!


Hi Jonathan,

The first thing I’d do is update the graphics drivers - they are over 4 years old. Can you still see the issues after that?


Thanks much. Unfortunately, there was never a newer driver offered for this model of the AMD in fact i have a newer driver than even offered any longer on the website. The computer Albeit still running is from 2010.

As Mentioned Rhino 5. Works fine.


It’s a subtle bug that I’m trying to figure out. I’m able to reproduce this on one of my machines and am trying to figure out the cause.

@Jonathan_A_Scelsa, please download the latest WIP that was made available yesterday. We believe that we finally found and fixed the black viewport bug that you were seeing. I would love to know if this WIP works on your computer now.


Hi guys, this just happened to me today on the laterst V7 WIP:

I have ran Rhino 6 for a few hours, multiple instances and then a Game engine, so I presume the driver needs a system boot, but Rhino 6 runs just fine.

Note that there are no windows. The default is 4 so this is not one maximzed like shown by the original poster.

Hei Jørgen - I take it this is not reproducible after a reboot?

Hi Wim, sorry, had to run and will check tomorrow :slight_smile: I expect it to work. Odd thing is that v6 continued to work just fine even after closing and reopening.

If it happens again…

Close ALL running rhinos…Then try starting V7.

If you see the problem still… Get SystemInfo for the running V7, then start V6 and get SystemInfo for it as well… see if there are any differences.


1 Like

Hi Jeff!
That sounds like a good idea, will do!

Good morning, V7 WIP is black to day as well, it was the first app I opened after the reboot, so here is the system info:

Opening V7 in Safe mode and closing it (did nothing) seems to have solved the problem so now the WIP is not black. If it happens again I will try to just open and close the WIP with out trying the safe mode, to see if it was just a coincidence.

Rhino 7 SR0 2020-1-7 (Public Build, 7.0.20007.12535, Git hash:master @ -removed-)
License type: Not For Resale Lab, build 2020-01-07
License details: Stand-Alone
Expires on: 2020-02-21

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: -removed-

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce RTX 2070 (NVidia) Memory: 8GB, Driver date: 7-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 432.00

Secondary graphics devices.
Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-25-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 7-24-2019
Driver Version:
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 7 WIP\Plug-ins\Commands.rhp “Commands” 7.0.20007.12535
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20007.12535
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20007.12535
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20007.12535
C:\Program Files\Rhino 7 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20007.12535
C:\Program Files\Rhino 7 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7 WIP\Plug-ins\Displacement.rhp “Displacement”

God morgen, Jørgen,

That doesn’t look good at all. I’d try fixing that before anything else.

Yes, plese do! :smiley:
Here is that same system info from when the dispaly is working good, after running v7 in safe mode once:

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-24-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

and from V6:

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-24-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Thanks, hopefully that gives @jeff some more ideas or questions.
(I would still try to completely uninstall all drivers for all GPUs and then do a clean install of the latest drivers. Do you have the recipe for doing that?)

Thanks Jorgen,

Since this seems reproducible…could you please get THE latest V7 WIP and see if you can still reproduce it… I checked something in yesterday that was an attempt to fix something similar (to your SystemInfo results).


1 Like