Was: No templates in WIP, Now Holo's Quadro 4k

I have tried to clean uninstall the WIP and reinstall, but now there are no templates when I start up. Maybe this is related to the black render display mode. @jeff, could there be a link?

The only “link” I think there is, is that there seems to be something not working right on your system, and as a result, multiple problems are manifesting themselves in Rhino. I’m assuming you’re still getting black viewports then with the 12/7 WIP?

This has been a problem in the WIPs for a while. I think it was recently fixed but I don’t recall seeing a fix come by for testing.
Most users didn’t see it because most users had template files installed before the installer was broken.

It just happened on my other system as well, no templates, latest build.
Might be a Norwegian windows 10 thing, or that my user is named Jørgen, Rhino has a loong history of not liking my “ø”.
(I never used that as my username before, but I figured I should test out the microsoft account thing, and, well there you go :slight_smile: )

I don’t think so. I think it’s a WIP installer bug.
I asked in today’s developer meeting and I think it’s still on Brian’s “Open” list.

1 Like

Yeah, same black thing with 12-7 on the Win10 64 bit Quadro 4000 (with latest drivers).
Imported into an empty scene (no template, no environment)

If I add an environment image then I get reflections, but no lighting.

Here I turned off “Advanced GPU Lighting” and added a rectangular light:

And if I add another light then it just calculates one light, not both… strange stuff.

You can remote control the machine one day if you like.

Turning OFF Advanced GPU lighting pretty much disables all rendering capabilities, and what you end up with is something that you would see in V4.

When you turn Advanced GPU Lighting and turn the Skylight OFF, what do you see?

Let’s try a simpler case… close everything down.

Start Rhino
Draw a box centered on the construction grid
Set Perspective view to Rendered

What are the results?

Note: Please make sure Rendered mode and render settings are all at their Default values.

Here’s what I get using a Quadro 6000

And just for consistency with your question… If I load your mini model, select all geometry, copy it to clipboard, create a new file and paste from clipboard…Here’s what my Rendered mode looks like:

So if I were to guess…it looks like SSAO isn’t working on your setup…so try turning it off and see what the results are…

Here it is with Skylight off:

After a clean uninstall with manual registry clean out and a fresh install of WIP, on the latest and previous drivers I get a completely black box on a black ground. The background is rendered correctly.

BUT, how do I turn off SSAO? Or the Skylight?
Do you mean setting the display mode to “Default lighting” instead of “Scene lighting?”

Maybe OT: On my other computer with the geForce 970, if I turn off Advanced GPU Lighting then the SSAO is still there, should it be?

Yes…by SSAO I mean the Skylight…which can be found as a Checkbox within the “Rendering” Panel Tab (around half way down).

Unfortunately, you’ve discovered one of the bigger confusions in the universe with regards to Advanced GPU Lighting, and SSAO (or shadows). SSAO is simply just “shadows” created from light cast around by the entire environment. Whereas other shadows have specific type and directions…the bottom line is that we’re talking about shadows here… It turns out you can have display modes that don’t use shadows, but may want to use Advanced Lighting for better Phong style shading (i.e. Shaded mode)…but I don’t think the reverse of that is true (where you would want shadows but not advanced lighting), or at least not wanted/required very often. So any time “Shadows” are turned on anywhere within a display mode, be it Options, Display Panel, or Rendering Panel (Skylight), it forces Rhino to use Advanced GPU Lighting. Therefore turning OFF Advanced GPU Lighting might not actually cause it to go away…as long as shadows are enabled. Back in early V5 I had written two sets of shaders…one set did Phong shading + shadows, the other did Gouraud shading + shadows. This was to accommodate the different combinations of Advanced GPU Lighting + Shadows that could arise. It also meant I now had to maintain two sets of shaders for everything…I decided to ditch that effort, and we’re left with where we are currently (i.e. What I just explained above).

Once you find the Skylight checkbox, uncheck it and see what your box (other scenes) looks like.

1 Like