Vports Black


#1

Vports are in black and not executed commands are displayed.


Viewports Black
(Rodrigo Bárcena) #2

@Jose_Miguel_Lanzilot
I think this has to do with your Graphic card/ drivers…
wiki.mcneel.com/rhino/5/video/troubleshooting


#3

Rhino 5 have not been presented to me any problems on the screen.

I send the report makes Rhino 6 on the system Window 7:

Rhino 6 SR0 2016-11-1 (Public Build, 6.0.16306.9301, Git hash:6.0.16306.09301 in branch n/a)

Windows 7 SP1 (Physical RAM: 7.9Gb)

Intel® HD Graphics 2000 (OpenGL ver:3.1.0 - Build 9.17.10.3114)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: Intel
Render version: 3.1
Shading Language: 1.40 - Intel Build 9.17.10.3114
Driver Date: 4-17-2013
Driver Version: 9.17.10.3114
Maximum Texture size: 8192 x 8192
Z-Buffer depth: 24 bits
Maximum Viewport size: 8192 x 8192
Total Video Memory: 2108 MB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” n/a
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” n/a
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement” n/a


(Nathan 'jesterKing' Letwory) #4

Do the viewports draw better when you disable hardware acceleration for OpenGL?

edit: you have very old drivers (from 2013), perhaps you can update them if there is a newer version available before you try disabling the hardware acceleration?

/Nathan


#5

@nathanletwory @stevebaer,

i do not see the checkbox to disable hardware acceleration in the current wip. Has this been removed permanently ?

c.


(John Brock) #6

Intel video cards prior to the 4000 , like your 2000, are not supported and can not be made to adequately support OpenGL.

The 4000 and newer chips can still be problematic depending on drivers and there may still be some special edge cases we need to fix for V6, but they are supported. If you are using a 4000 or newer and are seeing Rhino display problems, please report them with all the detail you are aware of.

That said, the Intel chips of any series will never be a good choice for OpenGL based applications like Rhino, as they are intended to extend battery life and are not accelerated.


(Steve Baer) #7

All that said we do want to support this card and you should not be getting black viewports. I consider this a bug that we need to try and fix. I develop on a computer with a newer Intel GPU and it works fine. I’ll have to think of what we can do to try and diagnose what exactly is going wrong.

In the meantime, you can disable hardware acceleration by going to the advanced settings in the Options dialog and filter for opengl. I am trying to hide this option because it should never be used unless absolutely necessary.


#8

That graphics card is recommended for Rhino 6?


(Steve Baer) #9

Our goal is to support all graphics card configurations possible. We need to figure out why you are getting black viewports in V6 before making any recommendations at all.


#10

That I think is the best answer. Thank you.


(Steve Baer) #11

What happens if you turn off antialiasing? Are the viewports still black in that case?


#12

When I turn off the anti-alias the screen remains black.


#13

Have you tried updating your drivers? They’re from 2013. --Mitch


#14

Obvious. Not found a more updated than this current driver.


(Steve Baer) #15

Isn’t this driver the correct one for your card?


#16

The following information is read on the INTEL support site:

When I activate the intel program to detect the drivers the message is:
“The drivers are Intel generic drivers. They do not include customizations that your manufacturer might have added to optimize your computing experience”

I have the Motherboard P861-M B3 Revision of ASUS. On the ASUS website the drivers are older than the one installed.


(Nathan 'jesterKing' Letwory) #17

I think the keyword here is might. Perhaps you could try installing the driver, and if it doesn’t improve (or rather deteriorate) then rollback to the previous one?

/Natahn


#18

I installed the latest version of the Intel drivers with date 2015. The result in the image below:

With Rhino 5, it looks like this


#19

Install the last Rhino WIP, the screen is black and the elements executed by the commands are invisible.


(Steve Baer) #20

Hi Jose,
I the latest WIP I added a test command called “TestGlWarnings”. Please run this command and restart Rhino. I would be interested to see if you get an error message and if so what the message is. This will help me find the general location in the display code where things are going wrong on your computer.

Thanks,
-Steve