WIP error on opening---4/11/2017


#1

Not sure what the issues is but it opens to the opening screen and then within about 15 seconds it closes and comes up with an Error Reporting dialog message box.

Brian


(Pascal Golay) #2

Hi Brian -My guess is this is the same as some of the other crashing reports… hopefully that is now fixed - please check the next WIP… should be better.

thanks,

-Pascal


#3

When will it come out…? Just my luck I have a meeting in the AM and I need the WIP…Guess that’s what I get for using the WIP in the first place…I rarely use R5 any more.

Brian


(Wim Dekeyser) #4

Does it crash when launching Rhino or when opening a file? If the latter, for the time being (a few more hours, hopefully), you could launch Rhino and then import. At least, that works here…


#5

Launching…I even uninstalled it and reinstalled it and still the same results…Same WIP works just fine on my desktop.

Brian


(Nathan 'jesterKing' Letwory) #6

The new WIP is out


#7

Same problem with the new WIP…I sent in a error report. I just downloaded the new wip today.

Brian


#8

Not sure if this helps or not but the shutdown always happens it seems when “Cycles” plug-in is trying load according to the the scroll at the bottom of the opening page.

Brian


(Nathan 'jesterKing' Letwory) #9

After starting Rhino WIP in safe mode could you please run SystemInformation and post the results to me?

Thank you.


#11

It will not start in safe mode either…

Brian


#12

@pascal,

Same problem here, it is stuck at the splash screen trying to initialize viewports. The error dialog comes up behind the splash screen visible from the taskbar. Trying to bring this in front fails, the splash jums in front.

Starting in save mode results in the same without splash, it crashes immediately but without splash screen, i’ll sent in the error report.

c.


(Nathan 'jesterKing' Letwory) #13

Starting in safe mode means Cycles plug-in is not loaded (I just verified that here), so this isn’t related to that…


#14

My splash screen says something about Cycles when it is trying to load (even in safe mode)…Now it may be saying cycles are skipped but either way that is when it crashes and goes to the Send error report dialog box.

Brian


#15

I can now get the WIP to open if I hit the Open tab on the splash screen and select a file…I then get a C++ runtime error but Rhino continues to run just fine.

Hope this helps…

Brian


#16

@pascal,

i now found a way through it, under

C:\ProgramData\McNeel\McNeelUpdate\DownloadCache\

found a new downloaded trunk version, after installing, WIP opened again.

c.


(Nathan 'jesterKing' Letwory) #17

How are you starting Rhino in safe mode? Did you alter the shortcut to take /safemode as command-line argument?


#18

I just started Windows 10 in safemode and then tried to open Rhino. I don’t even know how to begin to…“Did you alter the shortcut to take /safemode as command-line argument?” Sorry.

Brian


(Nathan 'jesterKing' Letwory) #19

Ah, you should have used the Rhino safemode. Sorry for even mentioning altering shortcuts, you should have the necessary link in your start menu:


#20

Here you go…

Rhino 6 SR0 2017-5-3 (Rhino WIP, 6.0.17123.9201, Git hash:master @ 41d6fb77f67992abaf1596eae935e6d81dcbd076)

Windows 10.0 SR0.0 or greater (Physical RAM: 6Gb)

Unknown (OpenGL ver:(null))

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 10-13-2015
Driver Version: 9.18.13.4192
Maximum Texture size: 64 x 64
Z-Buffer depth: 255 bits
Maximum Viewport size: 30 x 2146467840
Total Video Memory: 1 GB

C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” n/a


(Nathan 'jesterKing' Letwory) #21

Thanks, that is some weird information in there. Apparently you have some Nvidia GPU, do you know what model it is? From a quick search with driver version and date it seems it is an older card from possibly the first CUDA generation.

I am guessing the driver may be causing Rhino to crash. You can disable RhinoCycles while you are in safemode so that it doesn’t load in the normal mode. Uncheck RhinoCycles in plug-in options: