Rhino WIP 8 crashes immediately upon startup

Hello, the last thread related to this topic was over a year ago so I’m starting a new thread here. I just installed Rhino 8 WIP and it crashes immediately after starting up, before I can execute any command, etc. Has anyone dealt with this and discovered the issue?

For reference, I’m currently using Rhino 7 mostly on Windows 11. On startup of Rhino 8, I can see all the Vray panels undocked as one external plug-in that is loading up but unsure if that is an issue. Vray works fine on Rhino 7.

Thank you in advance!

Does the WIP start in Safe mode?

There are no crash reports associated with your email address, so I’m guessing Rhino’s crash reported is not coming up?

Moved to Serengeti category.

Hi Mario - please start V7 and run the SystemInfo command in Rhino and copy/paste the results here.


Correct, no crash report coming up. It does open in Safe Mode.

Systeminfo in Rhino 7 is:

Rhino 7 SR16 2022-3-8 (Rhino 7, 7.16.22067.13001, Git hash:master @ aa7902c94c5aa33511e60d30f82b636be43bc85f)
License type: Commercial, build 2022-03-08
License details: Cloud Zoo

Windows 10.0.22000 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP - Plugged in [97% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 2-3-2022 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3070 Ti Laptop GPU (NVidia) Memory: 8GB, Driver date: 1-28-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 511.65
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-28-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.22201.1402
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\RhinoBeat.7 (d6f60aad-2954-44ef-9054-904ca827b721)\\Rhino_7\RhinoBeat.7.rhp “RhinoBeat.7”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\NamedPositions.rhp “Named Position”

The GPU drivers; both Intel and Nvidia are stale. I’d update them using the vendor Web sites. Automatic chack for update tools do not work.
That said, the drivers are probably not the problem.

I suspect it’s one of your plug-ins.
While in Safe mode, go into Options > Plug-ins, and change the list filter at the top to “Plug-ins that do not ship with Rhino”.
Disable all of them.
Start Rhino normally and verify it opens.
Then one at a time, enable the plug-ins, restart, until you find the culprit.

Good luck

Thank you for your help. It was the Rhinobeat.7 plug-in. I’m not sure what this does and can’t find much information on it. Are you familiar with it?

Sorry, I’m not.
Maybe somebody here knows about it.
It might be on www.food4rhino.com too.

Glad you figured it out.

Great, thank you, John!

Hi Mario -
Apart from all that…

Note that the current stable version of Rhino 7 is 7.27!

I see your V7 is behind of several service releases too.
I’d get that updated.

Thank you, Wim & John for pointing that out.