Windows 8.1 compatibility

Hi, I run Rhinoceros 5 on my laptop with OS Windows 8 64bit.
After I upgraded to Windows 8.1 the program stopped working properly. When I draw a line the viewports start mixing and the tool bar disappear.
I tried to uninstall the program, deleted all files and installed again but the problem remains.
My pc is up to date and all drivers are in the latest version.

Sounds odd… I have machines with both 8.0 and 8.1 and no problems so far… What do you have for a video card and drivers? When you say “viewports start mixing” what exactly happens? You say the toolbars go away when you draw a line but do they come back when you finish the command? That sounds really like some bad video stuff…


yeah, a collegue runs Rhinoceros 5 on partitioned Mac with Windows 8.1 and no problems. I have double video card, a AMD Radeon HD 8800M (program should use this one) and an Intel HD Graphics 4000. AMD driver is Advanced Micro Devices, Inc. version
Toolbars disappear and dont come back and viewports shows other than they should (for example top shows perspective and so on…)

All other programs works smoothly and no problems with video card at all

Same problem as this one Amd radeon hd 8670m open gl issue
My pc is Samsung Series 7 Chronos

Are you sure your Rhino is using the Radeon? Can you post a screenshot of what your Options>View>OpenGL page looks like? Your drivers do not look up to date in any case though, from the AMD website, they list 14.9xx as the latest (you have 13.152)

There are some problems with the latest AMD drivers, but all that’s been reported are issues with object transparency where there should be none… Never heard of toolbars disappearing or viewports getting switched…


OK, missed that thread, as I don’t run AMD cards in any of my machines. Maybe they’ve got it fixed with the latest drivers, though. --Mitch

OpenGl sees the video card; I will try to update my driver with Beta Driver. Now toolbar is gray :frowning:

OK… Just to check, if you uncheck “use accelerated hardware modes” in the panel above, do things work correctly? Not suggesting this as a permanent solution, but just to make sure the problem is video drivers…

installed latest driver from AMD website and now viewport flickering is solved! :slight_smile: Any help for the sidebar and tools? thanks!

Have you tried ToolbarReset? --Mitch

it worked, of course :slight_smile: everything is fine now, thanks so much for the help!