Windows 10 out of memory. 32 GB installed


I have a brand new monster gaming rig with 32 GB RAM installed. I’m meshing a 3dm file when I get out of memory warning image.

I’m not sure why though. I’m pretty sure I’m launching the 64 bit version of rhino. I don’t get this erro ron my 3 year old laptop with 32 GB ram installed. Pagefile on the new system is 5 GB only where as it’s 32 GB on my laptop. What could be the problem?

Rhino only ever takes up 5 GB anyway according to Task manager:

What does Rhino 5 x64 say here for the available RAM? Right click menu or wait to see it in the cycle.

Regarding Windows paging file size, if the OS is on a SSD I think you can set this to ‘no paging file size’ or 0 mb… although emotions run high on this subject so don’t take my word for it, it’s just a thought. I’d compare the setting to the other machine where there isn’t an out of memory error too.

Out of curiosity, have you tried meshing the file in the v6 beta?

Hi Bjorn - I’d check for bad objects or degenerate (zero width) surfaces. Can you send us the file? (


Hi all, Thanks for the super quick feedback. Some comments:

OS is indeed on an SSD. Other machine is also on an SSD and have 32 GB paging, however it’s a laptop and I figured it perhaps was because of hibernation.

Have not tried the v6 beta at all yet.

The file does indeed contain a few bad surfaces, I’ll try delete them and run it again, however right now I’m stuck in a long memory diagnostics. So I can’t check that “Available physical memory just yet either”.

Sent you the file in PM

Ok, an update.

Memory seems available and ok



I did try to delete the bad objects and did a new export to FBX (which is the command that causes this issue) but the problem persists.

Rhino 32 vs. 64 bit. How to make sure!

We had some related confusion in my class; students would double-click on a Rhino file and discover that the V-Ray plug-in was not installed.

It took a while to discover that double-clicking a Rhino .3DM file launched the 32-bit Rhino, which did not have any 64-bit plug-ins … obviously. However, students would never know which version of Rhino was running – or that there was even two versions installed. It just not something that ever occurs to the average user.

Our new procedure is to launch Rhino (which is the 64-bit version) … THEN open a file.

hi! Yes, I’ve gone through some of those issues in the past aswell. But in this case I’ve made sure I’ve launched the 64 bit version at least.

The task manager screenshot also confirms it… --Mitch

1 Like

Hello bjornsyse,

I am struggling with the same issue. Were you able to figure out the way out for this error?

It would be very helpful.

Thank you